1

I am running Comodo Internet Security Firewall (6.3) and trying to connect to work using Cisco AnyConnect VPN client. I can make the connection but can't do anything else, not even ping by IP address.

The only solution I've found is to disable the Comodo Firewall Driver. That solution (along with the alternative: uninstalling Comodo) is mentioned in this article, but I would like to keep Comodo and the firewall driver in place.

As soon as I deselect the Comodo driver and press OK, things work; as soon as I reselect the driver and press OK, things stop working. As mentioned in the article, turning the firewall off does not solve the problem.

I tried setting the Alert Frequency to Very High, in an attempt to get a popup message reporting the problem, but this doesn't help. I've also changed a number of firewall rules to write to the firewall log, but still no clues.

Any other thoughts on how to solve this?

  • Use a VPN compatible firewall... – Fiasco Labs Nov 27 '14 at 5:36
2

As it is written here https://dotcio.rpi.edu/node/409

There are only two options:

    • Use Control Panel. Open Network and Internet option and there open Network and Sharing Center.

    • Select Change adapter settings, right-click on Cisco AnyConnect Secure Mobility Client Connection and there choose Properties.

    • Then deselect the Comodo driver and click OK.

  1. Delete Comodo

  • Thanks for replying, but I already mentioned this solution in my question and said that I was looking for something better. – jdigital Nov 27 '14 at 4:56
0

Yes, COMODO had a long history of not being compatible with VPNs however here is workaround:

Open Comodo->Firewall->Advanced->Network security policy->Add…->Select->Running processess…->System Idle Process (or System if you don’t see System Idle Process)

Now, you should be back to Application Network Access Control window.

Select Add…

Action: Allow Protocol,

IP Direction: Out,

Description: GRE Out Allowed Check, if you want, “Log as a firewall event if this rule is fired”

Source Address: Any (or select what you think is better),

Destination Address: Any (or select what you think is better),

IP Details: GRE

Hope it could help

  • Thanks for the response but this didn't solve the problem. I turned on logging for this rule (Allow / IP / Outgoing / GRE for System) and didn't see anything. – jdigital Jul 31 '14 at 3:53
0

I know this is a late answer, but it may help others.

  1. Go to Firewall Advanced Settings.  Set up a new network zone for the VPN.

  2. Still in Firewall Advanced settings, create new GLOBAL rules to allow all IP in/out to the VPN network zone.

This will allow pings and traceroute (but traceroute must have the -I option).

  • Windows has tracert not traceroute. tracert does not have a -I option. – DavidPostill Jul 18 '15 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.