5

I use sublime text for my editors. I love it for everything else but 1 thing which is so annoying according to me. Whenever I change my branch, it brings up a pop up saying that file has changed and if I want to reload the file. I have attached an image for it as well.

Popup Image

I have researched a lot on this and found few preferences: ignoreChanged and autoReloadChanged which are set to true. It doesn't make any difference. I need some help to fix this annoying issue. Any help will be greatly appreciated.

  • 1
    What would you rather it do? Automatically reload or simply ignore the change completely? You say in your question that both ignoreChanged and autoReloadChanged are both true, but they both can't be true, can they? – Steve Aug 8 '14 at 18:37
3

I cannot find the key words (ignoreChanged and autoReloadChanged) you mention in the current documentation of Sublime Text 3, so probably they are from version 2 or even older.

The relevant part from the default settings is IMHO:

// Always prompt before reloading a file, even if the file hasn't been
// modified. The default behavior is to automatically reload a file if it
// hasn't been edited. If a file has unsaved changes, a prompt will always
// be shown.
"always_prompt_for_file_reload": false,

As you can see this is disabled by default, but perhaps somewhere in you config (packages(?)) it gets activated. So try to set always_prompt_for_file_reload to false. Then Sublime Text silently reload a file if it detects any changes to it.

And please note the comment about unsaved files. I use the following setting, as I think it's quite handy, especially if you use focus follow mouse in your OS, but this might depend on you personal preferences:

// Set to true to automatically save files when switching to a different file
// or application
"save_on_focus_lost": false,
| improve this answer | |
  • It didn't work for me? Am I missing something? – emphaticsunshine Aug 12 '14 at 22:51
  • Have you tried to start from the default config, i.e. without personal config and without any plugins? – mpy Aug 13 '14 at 5:48
  • Doesn't work for me either. Windows 7 64b. – vmg Jul 5 '16 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.