5

I'm using HomePlug AV2 600 devices to connect upstairs with downstairs (router is downstairs). A check with iperf shows bandwidth of ~100Mbps, and data transferred on the local network from downstairs to upstairs is transferred at about that speed. Good times.

But when I try to access the Internet from upstairs, maximum throughput is only 40Mbps. Bad times.

If I try from downstairs, I get the full 80Mbps that my Internet connection allows. This is really puzzling, as I know the HomePlugs are working faster than that for local data.

Here's what my setup looks like (the router is connecting to a fibre modem using PPPoE, everything has gigabit ports, and all testing was using wired connections):

                         +----+                           
                         | PC |                           
                         +-+--+                           
                           |                              
                           |                              
                       +---+----+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+ PPPoE +-----------------+     +-----+----+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +----------+    

If I connect to the router downstairs (wired), then it works great:

                       +--------+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+ PPPoE +-----------------+     +-----+----+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +----------+    
                           |                              
                           |                              
                        +--+-+                            
                        | PC |                            
                        +----+                            

If I wire the downstairs HomePlug straight to the modem, and setup a PPPoE connection from the Windows 7 machine upstairs, it also works as expected:

                         +----+                           
                         | PC |                           
                         +-+--+                           
                           |                              
                           |                              
                       +---+----+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+            PPPoE              +-----+----+    
  | Modem +-------------------------------+ HomePlug |    
  +-------+                               +----------+    

I've also tried plugging the HomePlugs in right next to each other on the same floor, and get the same poor results:

    Downstairs                                          

  +-------+ PPPoE +-----------------+     +----------+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +-----+----+    
                                                |
                                                |
                               +----+     +-----+----+    
                               | PC +-----+ HomePlug |    
                               +----+     +-----+----+  

So the issue is only there when connecting to the Internet through both HomePlugs and the router, and only affects WAN traffic. I've tried replacing the router with a newer model, but get the same result. I also tried replacing the HomePlugs with a different brand (first tried Solwise, now Devolo).

I've also tried creating a PPTP VPN tunnel between my upstairs computer and the downstairs router - and this does inexplicably gives me the full bandwidth I would expect. But this relies on using DD-WRT on my router - and it's very flakey.

I'm at a loss, so any help would be much appreciated!

4
  • What speed do you get from the Upstairs PC, through upstairs switch, both HomePlugs, through the wireless router's LAN-side switch, to a machine plugged into a LAN port on the wireless router? Now take the downstairs machine and plug it into the WAN port of the wireless router instead of the modem (e.g. use static IP addresses to set up a point-to-point Ethernet WAN link; be sure to leave NAT on, but turn PPPoE off); what speed do you get from that WAN-connected machine all the way to the upstairs PC? – Spiff Jul 26 '14 at 5:09
  • @Spiff for the 1st part, speeds are ~100Mbps. I hadn't thought of trying the 2nd part, which seems like a good idea. But I can't get it to work in DD-WRT.. even tho I set a static IP, the downstairs machine still ends up with a default IP address (169.x.x.x or whatever) – Cocowalla Jul 28 '14 at 15:40
  • Your router won't serve DHCP out the WAN port. You have to give your WAN-connected machine a static IP on the same subnet as the static IP you gave your router, and set its default gateway to the static IP you gave the WAN port of the router. – Spiff Jul 28 '14 at 16:20
  • @Spiff that's exactly what I tried, but for some reason the machine still behaved as though it was attemping to get an IP via DHCP, and ipconfig showed a default '169.x' address instead of the static IP visible in the adapter settings. – Cocowalla Jul 28 '14 at 19:02
1

What happens if you plug both powerline devices into the same plug strip AND turn off every circuit breaker in the house except the one powering this circuit? (i.e. Eliminate all possible sources of powerline noise.) If you find this resolves your speed issue then turn breakers back on one at a time until you find which has the noise source (and it may not just be one, but you get the idea). The difference between protocols I expect is exactly that... other protocols have better error correction than TCP.

7
  • I guess this should have been a comment, rather than an answer? In the test where I plugged in right next to each other, I did have everything else switched off. What protocols are you referring to? I've only been testing using TCP. – Cocowalla Jul 24 '14 at 14:16
  • 1
    Depends on you point of view I suppose....Literally EVERYTIME I've sorted out connection and speed issues on a network that uses the home AC wiring it's been a powerline noise issue. Once the furnace motor, once transformers on low voltage lighting, once fluorescent lighting on a aquarium. As far as protocols in use, for example, 2 windows boxes use SMB (not TCP) to transfer a file between 2 boxes on the same network: it.cornell.edu/services/managed_servers/howto/file_transfer/… – Tyson Jul 24 '14 at 14:32
  • Just a note, SMB is a layer-5 protocol that operates on top of TCP. – Cocowalla Jul 24 '14 at 14:34
  • I've tried a variety of protocols, so I don't believe this to be the issue. If I try SFTP or SCP on the LAN over the 2 HomePlugs, it's very fast. If I try it wired directly to the router, to a cloud server, it's very fast. If I try it over the 2 HomePlugs to a cloud server... only max 40Mbps again. – Cocowalla Jul 24 '14 at 14:36
  • I take it that the GUI for your devices don't show correctables and uncorrectables, that alone would give you a much better picture. – Tyson Jul 24 '14 at 15:07
0

Well, I still haven't fixed it, but after flashing my router with DD-WRT firmware (TP-LINK Archer C7) I've got 2 reasonable workarounds.

  1. Connect using wireless, just for Internet access, and use the wired connection for the LAN. Using wireless 'n' I can get speeds up to 60Mbps. I've got an 'ac' router and adapter, but for some reason I can only get 30Mbps with that - I guess it's an issue with DD-WRT ('ac' support for my router seems to be new to DD-WRT)

  2. Enable a PPPoE server on the router, and have the upstairs machines connect to that, using their wired connection (i.e. over the HomePlugs). For some inexplicable reason, I get the full 80Mbps download speed doing this

I'd still love to know why on earth option 2 works, when the 'normal', non-PPPoE encapsulated WAN traffic is half the speed?!

2
0

I had the exact same issue with Devolo HomePlugs. At times, they even caused the ASDL connection to drop completely. They seemed to be causing issues with the router directly. This actually seems to be a common issue with them.

I since upgraded to TP-LINK's Which are working great with full speed connections and no issues yet.

I'd honestly say give another brand a try. If you still have issues, then return them.

Just to add: Not sure where you're from, but BT Infinity Fibre in the UK are known to have big issues with HomePlugs.

4
0

A bit late to the party. But I suspect that your problem is due to radio interference between your ADSL and your home plug.

Both the home plug and the ADSL work by sending radio signals down wires. The home plug uses your home's electrical mains wiring. The ADSL uses your phone lines.

Where a device is connected to both, there is the possibility of signals leaking on the other network. This causes interference.

If your ADSL modem has poor electrical isolation between the power supply and the phone line, the home plug may interfere with the ADSL connection and cause it to drop.

Normally mains hum on the phone line would not affect the ADSL since ADSL specifically avoids the mains frequency for this reason. The problem comes from the home plug introducing high frequency mains hum.

The solution is to isolate the ADSL equipment from the home plug signal. I personally used a surge protector myself.

3
  • Actually, if I setup a PPTP VPN between my upstairs computer and the downstairs router (still using the homeplugs), I inexplicably get all available bandwidth (I'll update my original question to note this). My homeplugs have a built-in filtered socket, and the modem is already plugged into this. Both of these seem to go against your hypothesis. – Cocowalla Aug 16 '16 at 13:18
  • @Cocowalla oh.. That sounds like an MTU mismatch then. The MTU on LAN is typically 1500 whilst ATM which is what PPPoE/A needs to add a few bytes for the wrapping. It sounds like PMTUD is failing with the home plugs installed. Can you try lowering the MTU on you PC's network card? – Aron Aug 16 '16 at 13:32
  • I had thought the same, and tried playing around with MTU settings, but to no avail :( – Cocowalla Aug 16 '16 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.