0

This has been a pain. My polycom voip phones (about 10 of them) are all losing registration every few hours. Each time I check them, some will be registered and some will not. Rebooting my firewall fixes the issue for a few hours (4-5 hours).

I'm using pfsense. The phones are set to reregister every 180 seconds.

What can I do to fix this issue?

-Thanks

1

I'm currently having the same issues.

Make sure you've done the following :

RTP

For this you will need the ports you setup in step 1.a above. I will be using my
port configuration. Add a NAT rule for RTP. This is essential or you will have
no audio or one way audio in your calls. Also change the NAT IP to whatever your 
Asterisk server is and change the description to something that makes sense for you.

Interface: WAN
Protocol: UDP
External port range: From: 10000
External port range: To: 20000
NAT IP: 192.168.1.50
Local Port: 10000
Description: Asterisk PBX - RTP
Enable Auto-add a firewall rule to permit traffic through this NAT rule

SIP

For this you will need the ports you setup in step 1.a above. I will be using my port
configuration. Add a NAT rule for SIP. This is essential or you won't be able to receive
calls and you may have trouble registering with your SIP provider. Also change the NAT IP
to whatever your Asterisk server is and change the description to something that makes
sense for you. 
Code:

Interface: WAN
Protocol: UDP
External port range: From: 5060
External port range: To: 5060
NAT IP: 192.168.1.50
Local Port: 5060
Description: Asterisk PBX - SIP
Enable Auto-add a firewall rule to permit traffic through this NAT rule

And also Disable port remapping

Click Firewall -> NAT, and the Outbound tab. Click "Manual Outbound NAT rule  
generation (Advanced Outbound NAT (AON))" and click Save. 
You will then see a rule at the bottom of the page labeled "Auto created rule for
LAN". Click + to copy that rule. Change the rule so it only covers the source IP of
your device that needs static port, and any other settings you need. Check the 
"static port" box on that page, and click Save. 
Move the rule to the top of the list. Apply changes and this behavior will be disabled. 

And then if all that doesn't work, you can also install the SIP Proxy daemon on pfSense


References: https://doc.pfsense.org/index.php/Asterisk_VoIP
https://doc.pfsense.org/index.php/VoIP_Configuration
https://doc.pfsense.org/index.php/Static_Port

  • So we're not using asterisk. We have tried a few services... Call centric, anveo, and voip.ms and all have the same issue. – user277244 Jul 22 '14 at 0:41
  • Even though the guides are for asterisk, the issue is the same. If the ports are forwarded then perhaps the port remapping is the issue. Have you disabled port remapping ? – Lawrence Jul 22 '14 at 0:46
  • static port has been set to yes. – user277244 Jul 22 '14 at 0:52
  • I would install the SIP proxy then. – Lawrence Jul 22 '14 at 0:57
  • OK I setup sip proxy and it did not work. I must have done something wrong because I could not get the phones to show up as using the proxy. I was unable to find any example scenarios for polycoms and pfsense using the sip proxy package. – user277244 Jul 22 '14 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.