0

I ran the command fdisk -l to find out what my external drive is formatted to, I found out it's uses GPT partitions and the filesystem is HFS+.

When I try and create a new folder on the external drive I receive the following message:

chmod: changing permissions of 'file_name/': Read-only file system

If I run mount this is the output:

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=dev)
/dev/sdc2 on /media/dev/andre backup type hfsplus (ro,nosuid,nodev,uhelper=udisks2)
/dev/sde2 on /media/dev/andre_clients type hfsplus (ro,nosuid,nodev,uhelper=udisks2)

So now I ran umount /dev/sde2 and unplugged the device then reconnected the device and ran the command dmesg | tail and got this information back:

[429154.613747] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.615995] sd 14:0:0:0: [sde] Test WP failed, assume Write Enabled
[429154.616993] sd 14:0:0:0: [sde] Asking for cache data failed
[429154.616997] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.669277]  sde: sde1 sde2
[429154.671369] sd 14:0:0:0: [sde] Test WP failed, assume Write Enabled
[429154.672742] sd 14:0:0:0: [sde] Asking for cache data failed
[429154.672747] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.672751] sd 14:0:0:0: [sde] Attached SCSI disk
[429157.047244] hfsplus: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.
1

I managed to find the answer with the help of @polym

Here is my findings on fixing this error:

Note:

It seems you need to mount a hfsplus as write/read, which is a bit problematic, because of it's journal function.

However, you can mount it as write/read as seen here and here.


The problem is that /dev/sde2 is mounted read only, according to the ro flag in the parentheses in the last line:

/dev/sde2 on /media/dev/andre_clients type hfsplus (ro,nosuid,nodev,uhelper=udisks2)

Therefore you can't change anything on this disk.

Remount it as read+write rw:

sudo mount -o remount,rw /partition/identifier /mount/point

In your case:

sudo mount -o remount,rw /dev/sde2 /media/dev/andre_clients

Before you do that, though, make sure you mount the right partition identifier by using dmesg | tail, e.g.:

[25341.272519] scsi 2:0:0:0: Direct-Access     [...]
[25341.273201] sd 2:0:0:0: Attached scsi generic sg1 type 0
[25341.284054] sd 2:0:0:0: [sde] Attached SCSI removable disk
              [...]
[25343.681773]  sde: sde2

The most recent sdX: sdXX line gives you a hint on which partition identifier (the sdXX one) your device connection is identified with.

You can also check which dev your device is connected to, by doing

ll /dev/disk/by-id/

This will give you all symbolic links of the device and it's partitions:

lrwxrwxrwx 1 root root   9 Jul 22 16:02 usb-manufacturername_*serialnumber* -> ../../sdb
lrwxrwxrwx 1 root root  10 Jul 22 16:02 usb-manufacturername_*serialnumber*-part1 -> ../../sdb1

If you wish to view this post in more depth follow this link

0

You're mixing differents things: partition table, partitions, filesystems, permissions, etc…

GPT is a type of partition table, which describes partitions on the disk. Those partitions contain a formatted filesystem. Like the error message says, it's the file system which cannot be written, either because it's mouted read-only (mount command will show the flag ro) or because it's not supported. For example by default you cannot write to a journalised HFS+ partition.

Paste the output of the mount command to allow us to know the file system and the mount options on that partition.

  • +10 @piernov thanks for you submit bro i changed the question to a more relevant title and relevant tags – Code Jul 23 '14 at 7:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.