2

I tried to install Cygwin (64 bit version) on my computer, and it went through hunky-dory until at the very end, autorebase.bat failed with exit code 1. I read through the logs and they weren't too helpful so I tried to run autorebase.bat on my own through a command line and I feel that the issue was Cygwin was trying to run the batch file from the wrong place, so it wasn't able to find dash (in cygwin/bin)

I manually ran autorebase.bat and it went through successfully.

My issue arises when I try to run zsh through the cygwin command prompt. This is what happens

link to image since I can't post images yet.

as you can probably tell, the word garble isn't desirable. I have a feeling it's due to zsh not being set up properly, but I don't know how I'd go about fixing it.

The second part is, once I have zsh up and running thanks to you guys, How does one run it through a third-party CLI tool. like Cmder?

Whenever I try to start a new cmder window, I set the executable to be zsh, and it runs, but it's missing most of it's commands (ls for example).

Thanks for the help everyone, this is a huge learning experience for me, which is why my request(s) may seem odd.

2

zsh is running properly, but there are syntax differences between bash and zsh for displaying the prompt.

You need to set the PS1 variable to something zsh recognises.

Edit your ~/.zshrc file and add something like

export PS1='%m%# '

Mine is quite complicated and set to

%*%F{green}[%K{black}%B%F{red}R%?%F{blue}S%L%F{magenta}J%j%b%F{green}]%n@%m%f[%!] %F{yellow}%~ %f%k
%#

but this may not work for you (depending on your zsh version and terminal type).

Have a look at EXPANSION OF PROMPT SEQUENCES in the zsh manual.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.