I got a function that checks whether the passed in file name is .
or ..
. But I don't know how to name it properly. Something like IsCurrentOrParentDirectory()
is ambiguous, since the function takes a file name and not a full path. (Intuitively a fellow programmer would expect passing /usr/
while I'm in /usr/
would return true
, while this is actually not the case.)
Is there a technical term for these directory entries? If there is one, what is it?
.
and..
are file names according to the POSIX standard. See my quote below. I'd say it's fine here as it's about general computing concepts.foo.bar
,foo
, ...) but not a path (foo/bar
,/foo/
, ...). But since directories, links, etc are files too, I will leave it like that.