2

Has the PackageID become case sensitive in Chocolatey versions higher than 0.9.8.23 in the install command? I am using an ‘Command Prompt’ on Win7 64bit and the package source is a private ProGet-server (v.3.1.0).

Here is what I have tried (notice the first letter in the PackageID!):

C:\Users\VMWIN764>cinst fileLocatorLite2014
The default install location has been changed . . .
Chocolatey (v0.9.8.27) is installing 'fileLocatorLite2014' and dependencies. By
installing you accept the license for 'fileLocatorLite2014' and each dependency
you are installing.
Unable to find version '1.0.0.820' of package 'fileLocatorLite2014'.

Command 'install' failed (sometimes this indicates a partial failure). Additiona
l info/packages: fileLocatorLite2014

C:\Users\VMWIN764>cinst FileLocatorLite2014
The default install location has been changed . . .
Chocolatey (v0.9.8.27) is installing 'FileLocatorLite2014' and dependencies. By
installing you accept the license for 'FileLocatorLite2014' and each dependency
you are installing.

FileLocatorLite2014 v1.0.0.820
Installing FileLocatorLite2014...
FileLocatorLite2014 has been installed.
Finished installing 'FileLocatorLite2014' and dependencies - if errors not shown
 in console, none detected. Check log for errors if unsure.

Reading the comments gave me the idea to view the server requests with Fiddler, because cinst with wrongly cased PackageID worked with Chocolatey 0.9.8.23 and it didn't with 0.9.8.27 while using the same ProGet-server for both tests!

So, Fiddler showed that 0.9.8.23 (which is using nuget.exe v2.1.31022.9038) issues the following request:

/nuget/Chocolatey_Tools/Packages()?$filter=tolower(Id)%20eq%20'googlechrome'&$orderby=Id

And in 0.9.8.27 (which is using nuget.exe v2.8.50506.491) the result is this:

/nuget/Chocolatey_Tools/FindPackagesById()?$filter=IsLatestVersion&$orderby=Version%20desc&$top=1&id='googlechrome'
/nuget/Chocolatey_Tools/Packages()?$filter=tolower(Id)%20eq%20'googlechrome'&$orderby=Id
/nuget/Chocolatey_Tools/Packages(Id='googlechrome',Version='33.0.1750.146')
  • What Sources for Chocolatey do you have setup? That package, regardless of the casing of the PackageID, doesn't exist on Chocolatey.org. In another test, I did choco install fiddler, and also choco install Fiddler, both of which worked. – Gary Ewan Park Jul 24 '14 at 5:59
  • Oh, you are correct: I forgot to mention that we use a company-internal package source hosted on a ProGet server. – frank koch Jul 24 '14 at 7:08
  • 1
    I don't have ProGet installed here, so I can't verify, however, what I can say is, Chocolatey, when targeting the Chocolatey.org feed isn't subject to case sensitive searches. However, obviously when targeting a feed in ProGet, it is. I wonder if it is possible to configure ProGet to not worry itself about case sensitivity? That part I don't know. – Gary Ewan Park Jul 24 '14 at 10:40
1

Chocolatey is not case sensitive but it appears that ProGet is (just wrapping up Gary's comments into an answer).

It does however look like something went into NuGet 2.8 that made things case sensitive. Which is FTL if the server side doesn't make up for this naming incompatibility.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.