1

What I want to do:

I want to put vertical letterboxes on the sides of my widescreen display to run a 4:3 resolution while maintaining the native pixel-for-pixel aspect ratio and scaling: my display is 1360×768, and I would like to end up with a desktop of 1024×768 with two 168-pixel-wide letterboxes occupying the remainder. N.B. I am reluctant to accept third-party software as a solution.

What I've got:

  • Windows 7 Home Premium
  • EVGA GeForce GTX 460 SE
  • NVIDIA Control Panel version 7.7.760.0

The display is a Dynex LCD DVD/TV combo DX-22LD150A11. It is using VGA input, which is provided through a hardware DVI adapter into a VGA cable (it has coax, VGA, HDMI, component, and USB inputs). It reports its native resolution to Windows as 1024×768, but most games detect native as 1360×768 (which corroborates what I found online in a service manual).

What I tried:

The NVIDIA Control Panel:

screenshot

has a setting called "Adjust desktop size and position".

  • The scaling setting aspect ratio claims, and I quote, "Stretches the desktop as much as possible to fit the display while maintaining the aspect ratio. If the desktop has a different aspect ratio than the display, there may be black bands around the desktop." That is precisely what I want, however when I change my resolution from 1360×768 to 1024×768, it stretches to fill my 16:9 display area anyways. It is also ineffective if I change my resolution first, then apply this scaling. I suspect this is because the control panel believes the monitor's native resolution to be 1024×768, which is quite noticeably and obviously not the actual native resolution of the display: I have tried many resolutions, including 1024×768 and 1366×768 and 1360×768 is the only resolution that does not blur any pixels. However, if that suspicion is correct, then it should letterbox if enter 1024×768 resolution, enable scaling, and then set a lower resolution (e.g., 800×600), it does not letterbox, instead stretching the desktop even worse.
  • The scaling setting no scaling claims "The display image remains the original size and is centered on your display screen. This may result in small, but crisp, image. The remaining area around the image is surrounded by black bars." This sounds similar to aspect ratio, but that it would be willing to letterbox both horizontally and vertically together; but it doesn't work either.
  • Have you tried the no scaling option that is present in your screenshot? – Michael Frank Jul 24 '14 at 1:19
  • @Michael Yes, it was originally set on no scaling and I have since returned it to that setting; I just reconfirmed that it makes no difference changing to/from that setting both before and after changing resolution. I'll add the flavour text of that option into the What I tried paragraph above, too. – muffin Jul 24 '14 at 2:08
  • Aaaand I just realized that the TV has a zoom mode... it was set to Wide Mode: Wide. Setting it to Wide Mode: Normal allows the display to letterbox (though it continues to override the no scaling setting, forcing the image to take up all the vertical space). (photo) Hmm... Should I delete this question or post my own answer since it's solved now? – muffin Jul 24 '14 at 2:29
  • Post it as an answer if you like. – Michael Frank Jul 24 '14 at 2:35
  • "Users with less than 10 reputation can't answer their own question for 8 hours after asking. You can answer 7/24/2014 9:08:59 AM. Until then please use comments, or edit your question instead." I'll be back tomorrow with the answer I wrote up! Thanks for the help @Michael. – muffin Jul 24 '14 at 3:14
1

For anyone googling this in the future and wanting an answer...

If you have Nvidia Control Panel, go to Display > Adjust desktop size and position

Go to the size tab, select a custom resolution that's native to your display (in either height or width) but with one side adjusted to 'fit' the target ratio.

In the case of 1920x1080 to 4:3 this would be 1440x1080.

Then, in the Scaling tab select the following:

"Select a scaling mode:" - Aspect Ratio

"Perform scaling on:" - GPU

Check off the override option.

Now if you load up a 4:3 game and go full screen, you'll maintain the black bars on the sides.

Cheers.

0

Change the settings on the display. This is an issue with the display, not the computer. Displays that serve as a television often have the ability to override the aspect ratio of the picture, because cable TV broadcasts and video DVDs sometimes need to be stretched or letterboxed to appear correctly.

In particular, the Dynex DX-22LD150A11 will override the aspect ratio even from a VGA input, stretching it to fit either vertically in a 4:3 letterbox or stretching it to fill the entire 16:9 display area. The zoom button changes between these two options.

  • I have successfully modified the display driver configuration on an ATI 5xxx series card to get it to display a strange resolution (I think 1598x900 or so) because I had some difficulty getting 1600x900 to work (I think it was an issue with the card BIOS). It involves changing the modelines specified in the driver INF file, but I would imagine it would work for any resolution provided you calculated everything correctly. – user55325 Jul 24 '14 at 19:45
  • @user55325 I'm afraid I don't understand what that has to do with this answer. This answer specifically pertains to the display device, not the graphics card. Changing software settings to get around BIOS issues sounds like a separate answer altogether. – muffin Jul 25 '14 at 11:46
  • I think what I was getting at was that even if display does not provide a native 4:3 "zoom" setting, you can still make it work by setting the video mode manually. – user55325 Jul 27 '14 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.