17

Using openSuse 13.1 with KDE and FF 25.0

In my bashrc -- both for root and user -- I use

xset b off

to disable the "beep on error" for all programs. FF seems to be the only one to ignore this, which is quite a nuisance as I do work frequently in a library where silence is imperiative. Using earplugs every time i search a website (strg-F) and the word is not found the "beep on error" -- always on full blast -- almost blows my brains out.

Is there an (advanced) FF setting I have overlooked?

3 Answers 3

33

Open in Firefox:
about:config

Search for:

accessibility.typeaheadfind.enablesound

and set the value to: false

Then restart Firefox.

4
  • 5
    you may need not restart firefox
    – Alex Jones
    Mar 27, 2019 at 11:04
  • 1
    No restart is needed in 2019, and thanks for solving these annoying beeps. Works on MacOS too.
    – sorin
    Apr 14, 2019 at 13:35
  • Playing a sound by default when the search string doesn't exist is a complete nonsense, thanks for the solution. I wonder where do Mozilla developers work, likely not in an open space.
    – mins
    Sep 12, 2022 at 13:59
  • @sorin using win 10 in 2023. Restart is not needed. I also set accessibility.typeaheadfind.soundURL to blank. Sep 18, 2023 at 22:11
1

To prevent any beep, sudo rmmod pcspkr will remove the kernel module that makes beep.

Writing blacklist pcspkr in /etc/modprobe.d/blacklist will prevent the module for being loaded again.

1
  • 1
    I don't think this is the way to go. OP wants to disble beep in FF and not for entire system
    – Alex Jones
    Mar 27, 2019 at 11:05
0

Use the alsamixer command. Hit F6, select your sound card. Use right arrow to navigate to the Beep bar. Either hold the down arrow until it is at zero or just hit the number 0.

Also, maybe you want Auto-Mute enabled. It's hard to tell. This will make it so you can have your laptop speakers at 0 and then plug in earbuds/headphones and they will have sound at a different setting. The disable of beep will still carryover, however.

1
  • Ecept the normal sound card, there is Console Audio Control, and I can't change the volume of it, even with sudo.
    – lolesque
    May 28, 2016 at 9:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .