4

I have scoured the internet for over 2 hours trying to find a solution that works to resolve this. I am trying to do a space escape in a .css file in Notepad++ and it just keeps showing this weird W thing (which I found out is the Korean currency symbol for "Won").

I've attempted all of the obvious and suggested fixes I was able to find - reinstalled Notepad++, changed the language settings, etc. It only does this in CSS files and it only does it in Notepad++. Another odd thing is that "Find"(Cntrl+F) results for "\" show this as the only instance in the file.

enter image description here

I want it to display

#status.En\ panne{...}

My two questions are:
1) Is there a way to resolve this?
2) Will just leaving it there still act as a space escape?

11
  • Check Control Panel -> Region and Language -> Administrative (Windows 7), what is set for "Language for non-Unicode programs"? I know if that's set to Japanese the \ appears as a Yen sign. It's just cosmetic though, it should still be \ in the file. – baochan Jul 24 '14 at 20:29
  • Did you try the 'encoding' menu item in notepadd++ and change the encoding? – dbza Jul 24 '14 at 20:32
  • Thanks for all the comments and answers. I will check all of these out and post my findings. – Mkalafut Jul 24 '14 at 20:38
  • @DBZ_A Yes I changed that and the font around several times to see if I can get any results. – Mkalafut Jul 24 '14 at 20:47
  • @baochan it shows as English (United States) – Mkalafut Jul 24 '14 at 20:48
5

Was able to reproduce the problem, not sure how this happened:

In Settings -> Style Configurator, choose CSS, and TAG. The font name defaults to "Batang", a Korean font. Select Font Name and choose the first (blank) selection, and Save&Close. That should fix it.

2
  • yaay! :) that relief when you get an answer for a puzzle-question like this! – dbza Jul 24 '14 at 21:09
  • Yep, it sure does. Thanks for the info everybody! – Mkalafut Jul 25 '14 at 12:43
2

I've seen this happen before on MP3 players, and my experience shows that this issue is caused by the software using the wrong character encoding to display the text.

Is Notepad++ set to use the correct character encoding? Regardless, this is most likely a character display issue; what is stored in the file is probably the correct binary code for the backslash character and the code should work correctly.

Edit: Based on your comments, the issue is likely due to Notepad++ using the wrong font for the CSS syntax highlighting. I can reproduce this myself with the text foo.bar\, so I'm pretty sure this is a bug in Notepad++.

Notepad++ bug: backslash displayed as backslash sign

Not the answer you're looking for? Browse other questions tagged or ask your own question.