0

I tried to configure /etc/dhcp/dhcpd.conf file in Linux but it failed as static addressing. How do I fix it? Am I missing any data and is it accurate? I need help.

Below is screenshot of my contents for the file.

ddns-update-style interim; ignore client updates; subnet 192.168.56.1 netmask 255.255.255.0 option subnet mask 255.255.255.0;

range dynamic bootp 192.168.0.25 192.168.0.200; default-lease-time 43200 max-lease-time 86400

3

your subnet and your range are in different networks. the range definition must be in the same network the subnet defines. Also, set your subnet address to .0, not 1. .1 is a host, .0 is a network. finally, every option must end with a semicolon (;)

...
subnet 192.168.56.0 netmask 255.255.255.0 {
       range dynamic bootp 192.168.56.25 192.168.56.200; 
       default-lease-time 43200; 
       max-lease-time 86400;
}
...

should work, assuming you are actually defining a pool for 192.168.56.0/24.

more info here: http://linux.die.net/man/5/dhcpd.conf

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.