0

I have Internet Explorer 11 on Win 7.

I go to the address : https://www.mozilla.org/en-US/products/download.html?product=firefox-stub&os=win&lang=fr

The dialog comes. I have the button Run. I click it, but it does not work : nothing happens. Usually, this button works. This is a nice feature, this is why I use IE.

How can I have the button Run work again ?

I have played with the options, to no avail.

Edits :

The button Open has the same problem when I request a document.

How can I have the button Open work again ?

8
  • you have to Run run again.
    – Smokey
    Commented Jul 25, 2014 at 8:11
  • is that the same with other executables you download in IE 11 ?
    – rob
    Commented Jul 25, 2014 at 8:24
  • @TheJoker - I have clicked several times on Run. To no avail. Commented Jul 25, 2014 at 8:47
  • Well....It's not the end of the world. :P Try with chrome or firefox. @Nicolas Barbulesco
    – Smokey
    Commented Jul 25, 2014 at 8:51
  • @rob - The problem occurs also on other sites, with other executable downloads. Commented Jul 25, 2014 at 8:51

2 Answers 2

2

Check security settings of browser and, if possible, restore it to default.

0

This could be due to security settings of Internet Explorer.

Try putting https://www.mozilla.org into Trusted Sites Zone.

Open Internet Explorer > Tools > Internet Options

Go to Security Tab

Select Trusted Sites

Click Site Button

Add website https://www.mozilla.org and close the bar.

Close IE and Reopen it, now you should be able to run the downloaded program.

Alternate

Run Internet Explorer in admin mode,

Start > All Programs > Right Click Internet Explorer and select "Run as admin"

Now you can download and run downloaded problem with run button after download.

Let me know if this helped or not.

1
  • I have tried that. That did not help. Commented Aug 18, 2014 at 11:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .