0

Windows 8.1 at work (no group policies) wants me to update my GPU drivers through Windows Update (it appears in my optional updates list). I'd rather do this manually since it gives me more control over what exactly is installed. Is there a way to tell Windows Update (the desktop version, not the Modern UI version) to not check for GPU driver updates?

My GPU is an AMD Radeon 7500-7600M series.

The official name for the update is "Advanced Micro Devices, Inc. - Graphics Adapter WDDM1.3 - AMD Radeon HD 7500M/7600M Series" and It's been released in July,2014.

screenshot of the update:

enter image description here

  • In update center right click on Update -> Update hide. – Watsche Jul 25 '14 at 12:24
  • Have you installed CCC (Catalyst Control Center) - here you can set "Check for update" or not – Leo Chapiro Jul 25 '14 at 12:25
  • @Watsche I'm looking for a more permanent solution. AFAIK, that will make it keep appearing again when a new version arrives. – Nzall Jul 25 '14 at 12:25
  • If you have a digitally signed AMD/Nvidia driver WIndows Update shouldn't be installing the generic display driver – Ramhound Jul 25 '14 at 12:35
  • The official name for the update is "Advanced Micro Devices, Inc. - Graphics Adapter WDDM1.3 - AMD Radeon HD 7500M/7600M Series" and It's been released in July,2014. – Nzall Jul 25 '14 at 12:37
1

The only solution I know of is a bit of killing a fly with a cannon. You will need to get a server edition of windows on your network and install the Windows Server Update Services (WSUS). What this does is allow you to have fine grained control of what updates are presented/installed to each computer on the network that uses the server as its update server (the server can be set by local settings or via GPOs).

It won't give you fine enough grained control to only stop GPU drivers, but you can turn off all driver updates but leaving on the rest of the updates you would get through the windows update system.

enter image description here

| improve this answer | |
0

One way you could do this is to is to hit the windows key+q and go to "change device installation settings" and tell windows to not search for driver updates.

| improve this answer | |
  • That option is already disabled. – Nzall Jul 25 '14 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.