17

When trying to install SQL Server 2008 Developer and Enterprise editions on a Windows 7 box I've got this message:

Rule "Restart computer" failed. A computer restart is required. You must restart this computer before installing SQL Server.

Of course I already restarted 10 times.

I've found a post in a forum saying that I should clear

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations

but I don't have such a key.

  • Are you running any other versions or instances of sql server or any other servers for that matter? – Troggy Dec 4 '09 at 19:52
  • I had sql server 2005 express installed with visual studio 2008. – pupeno Dec 5 '09 at 10:01
  • 2
    Clearing that Reg Key worked for me – Greg B Jan 7 '10 at 17:32
  • See also stackoverflow.com/questions/176857/… – Vadzim Jan 12 '15 at 16:02
10

.... after installing SQL Server 2008 Express, put the value (might be multiple lines) back into this setting. So copy them somewhere!

Fix:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager is the path. Session Manager is the folder. PendingFileRenameOperations is the setting. Clear the value in that setting.

Common mistake:

You'll notice that there are more folders under the Session Manager folder. Don't look there. Those are sub-folders. Once you've clicked on the Session Manager folder, find the setting on the right.

7

I've tried SkipRules option from another answer with SQL Server Express 2014:

  • run SQLEXPRWT_x86_ENU.exe just to extract files then close it

  • cd SQLEXPRWT_x86_ENU

  • setup.exe /ACTION=INSTALL /X86 /SkipRules=RebootRequiredCheck

Then the setup process didn't complain on "Reboot required" rule but still failed at the end with the following messages:

A previous installation required a reboot of the machine for changes to take effect. To proceed, restart your computer and then run Setup again.

One or more affected files have operations pending. You must restart your computer after the setup process is completed.

Then I tried to temporarily delete both registry keys HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired mentioned in other answers here. After that setup run smoothly and everything worked without reboot.

  • My SQL Server wouldn't start and required a reinstall, this was the only way to get rid of it. – Flonk Oct 17 '16 at 11:08
6

like stated in http://blogs.msdn.com/b/hansr/archive/2006/02/17/patchreboot.aspx there is also an important key from windowsupdate

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired

this must also be 0 or not present.

2

When the tricks with clearing the registry keys don't work: - HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired

You might try a reboot from the command line. Press Windows+R for the "Run" dialog box and type cmd and press enter to start the command line.

The command for a forced reboot with zero seconds delay is "shutdown -r -f -t 0".

This might be handy when you use a Windows 8 computer or a Win8.1 because a shutdown is sometimes not a real shutdown but a "hybrid shutdown" which is in fact a hibernate state to enable "Fast Boot".

  • +1 this was the only thing that worked out of the suggestions in this thread and the MSDN threads. – codenheim Jul 22 '15 at 17:24
1

Go into Windows -> Control Panel -> Administrative Tools -> Services and stop all of the SQL Server Services. Then just hit Re-run.

  • This worked for me without a reboot! Thanks. – Ionian316 Aug 17 '17 at 14:44
0

Maybe there's a better solution, but the only one I could find was re-installing. Mental note: always install SQL Server first.

0

I had the same issue. when I restarted the machine it was working fine.it was due to windows updates in pending.

0

Step 1: Open the registry. For open registry, press window key + R and type

Step 2: Type regedit and press enter button

Step 3: Now selectHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

Step 4: Double click "PendingFileRenameOperations"

Step 5: Delete all data from Value data textbox.

Step 6: Press OK and close the registry.

Now try to run SQL Server 2008 setup again. I hope Restart computer failed error not come again.

  • 1
    welcome to superuser, your answer is close to other answers, it may help you could point out differences as the OP only could get a re-install to make it work. This will help future readers. again welcome to superuser – mic84 Mar 9 '18 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.