I've recently been handed a 6 year old laptop (HP Pavilion ZD7000) that I want to repurpose for a family member to use. It was boxed and unused when it was given to me.

However, upon boot, after the BIOS screen it is showing a black screen with a cursor, with the words "Operating System Not Found" occasionally flickering up.

  • I've run the XP installation disk and all appears to install successfully; but, upon boot, same problem -- operating system not found. Despite the fact that if I boot up from a Linux LiveCD I can mount the Windows partition and see that all of the Windows OS files are on there.

  • I've tried Linux and GRUB. I can format the whole drive, install Linux to disk, but still only get "Operating System Not Found" at boot. No GRUB, no nothing. But if I mount the drive from a LiveCD, all the OS files are visible.

So the hard drive itself seems fine. It's entirely accessible and I can read/write on it once booted from a CD. I can only guess that there's some hardware problem stopping the hard drive being visible to the BIOS, or maybe a problem with the BIOS itself? It appears that it's just not visible to the BIOS.

That's as far as my hardware/BIOS knowledge goes. Can anyone suggest what I might need to do to the hardware or to the BIOS in order to get it to see the drive?

  • i have just about the same problem out of a 7-yr-old Compaq; i managed to get Windows or Linux installed on it, then after a few reboots it can't boot from the hard drive anymore. never did find the problem tho. – quack quixote Jan 23 '10 at 17:18

One (or more) of three things probably going on here:

  1. The basic input/output system (BIOS) does not detect the hard disk.
    • The hard disk is damaged.
    • Sector 0 of the physical hard disk drive has an incorrect or malformed master boot record (MBR).

You could try testing the disk, but it's probably easier to slap in a new drive & save yourself the trouble.

  • 1
    I think it must be answer 1. Because for 2, I can use the hard drive from a LiveCD. And after trying to run a disk test from the BIOS, it just says 'No IDE Device'. So it's never even getting to the MBR. So the question becomes... why does the BIOS not detect the hard disk... hmm. – ngm Dec 4 '09 at 16:25
  • 1
    It could also be #3. Sounds like you have some physical damage to the disk. You could try install-mbr /dev/hdX on your drive when running from the live CD. You may need to reinstall GRUB after that. If still no joy, I would go shopping. A new disk is probably cheaper than your time. – DaveParillo Dec 4 '09 at 16:50

You might check the BIOS to see what the boot order is. If someone set it to only boot from CD or Network or might have set it to not boot from the hard disk. The other option I can think of is the hard drive boot sector is hosed.


Are there any diagnostics on the laptop. Some like the Lenovo and Dell have a minimal diagnostic in the BIOS and then a diagnostic partition on the drive ( not any help if drive is bad) On a Dell you press F12 and on an IBM/Lenovo there is a dedicated button.

If there is a diagnostic, you can run that. Failing that, you can get a 2.5" to IDE adapter or 2.5 to USB at most computer shops and connect to a working desktop system and run a diagnostic on the drive. Some drive vendors like Western Digital and Seagate also have their own diagnostics. They only work with their drives I belive. I am sure there are lots of other tools for this but if you have a known good PC and attach the drive, you can eliminate all the laptop hardware in one test

  • Thanks. There is a diagnostic in the BIOS, named HDD Self-test. There are 2 options: Execute Short Test and Execute Long Test. If I run either of those, however, I am given 'Test Status: No IDE Device. – ngm Dec 4 '09 at 17:01
  • Looks like drive is bad Connecting to a USB to 2.5 or USB to IDE for a desktop may allow you to run more detailed tests. – Dave M Dec 4 '09 at 17:52

Agreeing with other posters that the problem is likely in the drive hardware. If you have another laptop (and feel brave) you could swap the hard drives (if they're both IDE). If the non-booting box detects the drive from the other one, then you know the problem is in the Toshiba drive. If your other laptop detects the Toshiba drive, you know the problem is in the non-working system. (This is a case of the "binary swap" test.)

Back up the known good drive before trying this!


Sounds like there might not be any boot instructions. I'm not a Windows user, and I don't know what kind of bootloader system Windows uses, but I would try reinstalling the bootloader, or even installing GRUB which can boot Windows although that's not an ideal solution.

  • I've tried installing Linux and GRUB, but I still get the same problem. It's as if the BIOS doesn't actually see the disk at all. – ngm Dec 4 '09 at 15:54
  • Is the disk set as primary master? Usually that's just a BIOS setting but on an old computer I have, it has to be plugged in to the cable chain in a certain order. – Reynolds Dec 4 '09 at 15:58
  • According to the jumper documentation (linked to in original question), I believe it's set as master. Out of interest, what does the term 'cable chain' refer to? Is it more related to hardware setup for desktop/tower computers? This is a laptop, and I can't see any cables at all. – ngm Dec 4 '09 at 16:21
  • I didn't know we were dealing with a laptop. IDE cables often have multiple connectors to "chain" HDDs together, and on some old computers the order you plugged them into on the cable determined master/slave relationships. – Reynolds Dec 4 '09 at 16:36

You might be fighting an old worn-out cable. Old IDE cables can be flakey. Try disconnecting it from the motherboard and drive, and then plugging it back in again. This will sometimes improve the contact on the signal pins. If this doesn't work, try swapping out your IDE cable for a new one.

How long is your IDE cable? I've seen IDE cables that are longer than what is "acceptable". Too long of an IDE cable can introduce signal integrity and timing issues.

  • The computer I'm working with is a laptop, so I'm not sure if there's an IDE cable as such. Everything looks very fixed and integrated. And, if there was a cable problem, would that not mean I wouldn't be able to use the drive at all? As it is I can see the disk and read/write to it once booted from a LiveCD. – ngm Dec 4 '09 at 16:08

you might try deleting all the partitians on the drive, recreate and do a full format. If this doesn't work, it could be something with the IDE connector on the motherboard.


Some HP machines have been setup with a hardware limitation of how big of a hard drive that can be installed. I have a HP Compaq Business Notebook nx9100 which has a physical limitation of less than 80 gigs of harddrive. I know this because I tried installing both a PATA 160gig and a PATA 100 gig harddrive which both did the exact same thing that you described. If the hard drive that you're moving from one laptop to another happens to be larger than that phsyical limitation then this could be the cause of your problem.

Hope this helps and good luck.


If you have a Phoenix BIOS be sure to check on the Boot Order screen for the "!" character in front of a Boot Item. It signifies that it has been disabled from booting.

  • The BIOS on most HP laptops is from Insyde Software, not Phoenix Technologies. – bwDraco Oct 11 '12 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.