0

I am trying to connect two computers together using a Cat6 cable. Both computers have gigabit Ethernet cards, and the "Network" tab in Task Manager reports the link speed to be 1Gb/s for both. One computer is running Win7 x64, and the other is running Win8 x64. At the point of testing, both computers were disconnected from WiFi and were assigned static IP addresses 192.168.10.1 and 2.

Testing with iperf reports approximately 430Mb/s throughput, which is nowhere near the reported link speed of 1 Gb/s.

  1. I've tried replacing the cable with a second, new, Cat6e cable, as well as a Cat5e cable, but the average throughput remains roughly (+/- 50Mb/s) the same.

  2. I've tried going into Device Manager and changing "auto-negotiation" to "1.0 Gbps full duplex" on both computers. Not that it should make a difference, since both sides would have auto-negotiated to 1.0 Gbps anyway.

Is there something I'm missing out here?

  • Is the cat6e cable professional grade or homemade? and how long is it? – Tyson Jul 26 '14 at 17:17
  • 2
    Have you enabled jumbo frames? – ChrisInEdmonton Jul 26 '14 at 17:30
  • 1
    If the link speed is negotiated at 1 Gbps, and remains there, it is unlikely that there is a problem with the cable. For short runs, 1000BASE-T usually works over garbage cable it's not supposed to just fine. – tgies Jul 26 '14 at 18:12
  • @ChrisInEdmonton Even with standard 1500 Byte frames, TCP/IPv4 over gigabit Ethernet is 94% efficient (940+ Mbps). Jumbo 9000 Byte frames just let you squeeze another 4-5% out of the link. – Spiff Jul 26 '14 at 18:42
  • Louie, what TCP window size did iperf report? Just for giggles, force it huge by adding -w 2M to both iperf command lines. What chipsets do your gigabit Ethernet interfaces (NICs) use? I'm leaning toward an answer of "you just have crappy NICs". – Spiff Jul 26 '14 at 18:46
0

EDIT: I originally stupidly mis-read the OP and didn't see that he was already using a load-testing program. I've decided to leave a few lines of my original post in place though, in case anyone else arrives at this page with a similar issue but using file-copy testing.

For anyone else arriving at this page who is not using iperf or similar, always consider computer-based bottlenecks when doing network load-testing, and beware that as you approach Gigabit speeds, your storage medium or other system components may start to become limiting factors. If you don't have access to iperf or similar, consider setting up temporary RAM-disks (a.k.a. RAM-drives) on both computers.

  • As the OP is testing with iperf, the HDDs do not factor in to this. The OP is testing wtih a network load-testing app. – Lawrence Jul 28 '14 at 9:05
  • Argh, my bad, was reading too fast and didn't see 'iperf' - sorry for that. Should I vote to delete my post? It adds nothing to the discussion (and I feel kinda embarrassed for not reading the OP's post properly) – smashingly Jul 31 '14 at 0:39
  • No problems, up to you :) still helpful if someone comes across this if they're doing a file transfer between 2 computers 'and not getting gigabit speeds' – Lawrence Jul 31 '14 at 1:14
  • I did a bit of both - heavily edited out most of it, but left pertinent info in there. Thanks for the guidance and understanding; it was one of my first answers and I jumped the gun a bit ;) – smashingly Jul 31 '14 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.