2

I'm using sublime as my main text editor and I am remapping my arrow keys from the arrows to alt+i, alt+j, alt+k, and alt+l.

I have noticed that on Ubuntu 14.04 after I remap my keys that when I click alt+i the menu at the top of sublime is now in focus and has a drop down opened up! The other 3 keys seem to work for moving the cursor.

I have tried to figure out how to disable the menu bar at the top of the screen from getting selected anytime alt+i is pressed but I can't figure it out. I'm pretty sure it is an operating system problem as opposed to a sublime issue.

Can anyone shed a little light on the subject? I have already tried to disable the "activate the window menu" in keyboard shortcuts. It didn't seem to work on Ubuntu 14.04.

0

Found one solution. The way to do it is to disable app menus from appearing and you can achieve this by doing these two commands:

sudo su; echo "export UBUNTU_MENUPROXY=0" > /etc/X11/Xsession.d/81ubuntumenuproxy;

After these commands restart your computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.