Recently I've started encountering a weird bug in my Windows 7 x64. I have an Asus N53SV with an Intel Centrino Wireless-N 1000. When I physically move the laptop, eg. move it to another room or just nudge it a little bit when it is sitting on my lap, it loses signal. I still see 5 signal bars on my taskbar, but I lose Internet connection and when I click the icon in my taskbar, I only see the hotspot I'm currently connected too (normally I see ~24 hotspots around my house). Soon after, an orange triangle with an exclamation mark shows up on the icon saying that I have limited connection.

To temporarily fix the issue, I need to disable and then enable the wireless adapter again, or reboot the laptop. As you can imagine, it can get very annoying very fast. I've been using a USB wi-fi since to be able to normally work. However, before sending it to RMA, I decided to boot up one of my old Linux live CDs (Linux Mint 10) to see if it acts weird, too (then I could say for sure it's a hardware fault). The thing is, it doesn't! I literally can't make it lose connection now.

I hadn't changed any drivers in my laptop and when it started doing that, I uninstalled my wi-fi drivers and installed older ones. What do you guys think about the issue? Have you ever encountered something like that? Any ideas what could fix it except for reinstalling the OS? Thanks!

  • WiFi is radio waves, and those are shielded by metal (i.e., in building walls) and to a lesser degree by other materials. Reflections and other phenomena can interfere with the reception. Besides, the WiFi range is increasingly crowded, if a nearby WiFi access point is using the same channel you are using, mowing around cn make that one mask the signal of yours. – vonbrand Jul 27 '14 at 18:31
  • No other PCs in my house are having this problem. Also, I don't believe there would be any kind of shielding that would shield wi-fi signal from all 24 hotspots at once by just touching the laptop. – Filip Vondrášek Jul 27 '14 at 19:18
  • Sensitivity varies quite a bit between machines – vonbrand Jul 27 '14 at 23:07
  • But this one was working perfectly fine for 2 years. :( – Filip Vondrášek Jul 28 '14 at 9:28

As the problem isn't accruing with Linux it seems that it is windows so the only thing i could think of is that it is a driver problem. I have google'd your laptop and i have found these driver's. Try installing the 5 drives under Wireless (5).

As you have said you haven't changed any drives so the problem could of been windows update giving you the wrong ones. Strangely enough this happens to me when i reinstall windows and for some reason it stop's doing this after about 2-3 days.

Another idea is that it could be a fault with windows 7 x64 because i never had this problem until i bought so new ram and upgraded to 64 bit.

The best solution if the driver one doesn't work then just leave it for a few days and wait until your laptop isn't sulking. (+1 for using Linux Mint :-))

| improve this answer | |
  • Thank you very much for your answer, it really might be an update from Windows Update. I'll see what I can do about it. :) – Filip Vondrášek Jul 27 '14 at 18:24
  • I looked at recently installed updates and nothing even remotely connected to wi-fi or networking at all. :( I'll see if next month's updates fix it. If not, I just might reinstall the system after all, at least I'd get a clean system once again. :) – Filip Vondrášek Jul 28 '14 at 17:25
  • Seems I have fixed it. Finally! If you're interested, see accepted answer. Thank you very much for your help. :) – Filip Vondrášek Aug 15 '14 at 1:08

My guess is window's update.

Surprising I had the exact same problem with my windows 7 x64 laptop. I had concluded the problem was heat related and gave up trying to solve it. Like you I discovered disabling and enabling the wireless adapter solved the issue, for awhile. In my case, there is a keyboard function to toggle wireless, so while the issue was annoying it didn't bother to much to just hit the wireless key off, count to 3, and click it back on. although the lost 15 seconds of time while the connection was renegotiated was annoying.

Now that I read this question tho, I realize the problem has magically disappeared. It's been more than a month since I've seen that annoying yellow triangle. The only thing I can imagine that is different is updates that have been installed via windows update.

| improve this answer | |
  • Thank you very much for your answer. It actually might really be Windows Update now that I think about it. I installed Windows Update on July 9th and as far as I remember, that also might be the time when it started acting wrong. I'll try to search what do the individual updates that I've installed do. :) I won't accept the answer as of now, though, in case someone pointed me to a particular update. If that doesn't happen, however, I'll accept yours. :) Thanks again! :) – Filip Vondrášek Jul 27 '14 at 18:24
  • I've now confirmed that my prior hypothesis that the issue was heat related is most likely not true. I purposely blocked the vent and ran a 3D graphics editor that heats my laptop up anyway. Once the laptop was good and warm I unblocked the vents and continued use of the graphics editor, keeping the temp up. The internet connection never dropped. The problem seems to have left my laptop just like it came.... mysteriously. – Tyson Jul 30 '14 at 15:02
  • You're luckier than me, then! :) I'm still waiting for a new batch of Win Update to see if it solves anything and if not, then I'll probably just reinstall the whole laptop. Or I might try some kind of driver sweeper first and uninstall everything wifi related (and then install it again). – Filip Vondrášek Jul 30 '14 at 18:02
  • Seems I have fixed it. Finally! If you're interested, see accepted answer. Thank you very much for your help. :) – Filip Vondrášek Aug 15 '14 at 1:09

Turns out it was a HW problem after all. I opened my laptop, tightened the screws inside, blew off the dust and I haven't lost the adapter since (it's been over a week now).


It turned out to really be a software problem after all. I patiently waited for the new batch of Windows Update only to find out it solved nothing. What I did was uninstall the wifi adapter in Device Manager (with "Uninstall software" checkbox checked). Then I went to Programs and functions in Control Panel, uninstall Intel Wifi Proset application and rebooted. When starting Windows again a black screen I had never seen before in my life popped out saying something about "operations are in progress x/64 - path" where x was the number of the current operation and path was a registry key.

After I logged in I right clicked on the now unknow Network Adapter in Device Manager and selected Install drivers. It searched for a bit and then installed 2009 drivers made by Intel. The adapter name even changed from "Intel Centrino Wireless-N 1000" to "Intel(R) WiFi Link 1000 BGN." After some testing it seems to be working. I don't really like having 2009 drivers in a PC I otherwise tend to keep as much up to date as I can, but hey. As long as it finally works after so much pain and cursing... I'm not going to fix something that ain't broken... yet. ;)

I should also add that when I tried to uninstall the drivers for the first time, I must have forgotten some parts of it, so if you - yes, I'm pointing at you - appear to have a similar problem as I was having, double check if you really uninstalled everything even remotely Intel Wifi related.

Thank you all for your answers, I really appreciate it, guys. I also googled a bit (again, I did that even before asking this question, I'm not one of those guys who are not aware of "Search" buttons) and discovered a lot of users are having similar problems. If this answer helps at least one person, I'll be glad. Cheers!

| improve this answer | |

I've had the same problem with the same laptop for a while and I tried many things to fix it. Ranging from trying old drivers to a completely new Windows installation. My problems started after I had to replace my AC board (which was broken).

The problem is caused by the two WiFi antennas moving around ever so slightly on the adapter. They are taped down by the manufacturers, but (in my case) by removing the tape to remove the AC board the tape probably didn't stick as well. Maybe in your case the tape wore out and came loose.

By taping the WiFi antennas down properly I can now shake my laptop around and it won't disconnect anymore. Moving my legs underneath it when having it on my lap would disconnect it before that. It might be due to the screen moving back and forth a bit, pulling on the antennas.

Hope this helps!

| improve this answer | |
  • Thank you very much for your answer, it definitely sounds like the most probable reason. Please, have an upvote. :) However, this laptop is slowly falling apart - now my power connector is loose and I can't even slightly move it or it stops charging. I'll be buying a new laptop in the coming weeks. – Filip Vondrášek Jan 3 '15 at 5:39

I had problem with netbook ASUS VivoBook E200HA, but probably this can happen on others. After some time network adapter Qualcomm Atheros Wireless device stop working. Restarting and disabling device helped for some time and then this repeats. As I noticed after when I move netbook internet disappears. Reinstalling drivers and operation systems did not help. I find the problem and fixed it, so I want to share with you, and hope to help who has the same issue. This information would help me a lot. Problem was unscrewed screws, in the bottom of netbook. So I just tightened the screws and all works perfectly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.