2

Today I have installed GitHub For Windows. I had installed GitHub for Windows earlier and at that time it worked fine, but due to some reason I had to uninstall it.

Today when I installed GitHub again it installed perfectly. But after installation when I click on the icon, GitHub does not open. I checked Task Manager for processes and for some time I can see Github.exe, but after some time it disappears.

When it did'nt work I uninstalled and installed again, but the results are the same.

When I try to open it, only the loading symbols comes up.

  • 1
    Why the downvote? It is completely on topic. – Kartik Jul 28 '14 at 13:48
  • Related to this: superuser.com/questions/789029/… ? – Hannu Jul 28 '14 at 14:42
  • @Hannu No it's not related – Kartik Jul 28 '14 at 14:44
  • @Hannu One of my friends was able to do it perfectly on his own computer. – Kartik Jul 28 '14 at 14:45
  • firewall too strict? – Hannu Jul 28 '14 at 14:47
6

I was having the same problem as you had. I installed GitHub before, and it worked fine. I uninstalled it then trying to reinstall it, but nothing happens whenever I click the GitHub icon.

Deleting the GitHub folders left behind from AppData\Local and Roaming folders helped me solve my problem. Then I reinstalled GitHub and now it works.

  • From the Windows Start menu, choose Run (or Windows Key + R)
  • Enter the following, depending on your version of Windows, and then click the OK button:

On Windows Vista or higher, delete the %LocalAppData%\GitHub and the %AppData%\GitHub directories.

On Windows XP, delete the %USERPROFILE%\Local Settings\Application Data\GitHub directory.

Source: Uninstalling GitHub for Windows

| improve this answer | |
  • I have GitHub Desktop and it wasn't opening after I updated it. I opened %LocalAppData%\GitHubDesktop and I saw 2 applications. GitHubDesktop.exe and GitHub Desktop.exe (space). I opened the one with the newer modified date and it opened. – user719403 Aug 8 '17 at 21:00
1

If you are unable to delete the GitHub folder as described above, end the ssh-agent.exe process from Task Manager in Windows. Then, immediately delete the folder.

Task Manager >> Processes >> ssh-agent.exe>> End Process

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.