I have a new Azure VM (the Visual Studio Professional 14 CTP 2 Windows Server 2012 R2 image) and I'm trying to install SQL Server on it. The installation fails because it cannot see the .NET Framework 3.5 installed. There are two ways I know of to fix this, one is to run

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:"D:\sxs"

from an elevated command prompt and one is to enable the feature in the Add Roles and Features Wizard.

In each case I need the location of the source files. I think this would usually be on one's installation disk but since I'm on an Azure VM there is no installation disk. What should I use as the source path? How do I enable the .NET Framework 3.5 on an Azure VM created from a Windows Server 2012 R2 image?

4 Answers 4


From Unable to install .NET Framework 3.5 feature in Azure Windows Server images:

You will get the error if the conditions listed below are valid:

  1. The virtual machine is part of an Azure Virtual Network

  2. DNS server(s) are added to the Azure Virtual Network configuration

  3. Those DNS server do not have a forward to an external DNS server able to resolve internet based servers.

So you need to ensure that your DNS resolution/forwarding is working correctly so that public DNS names are resolved, or change the VM settings to not use the AVN.

Doing the latter will cause the VM to get it's (DNS) settings from MS's DHCP servers, and it will be able to resolve public addresses. You don't want to do this if your server is a DC, in which case you would setup your local DNS properly (with forwarders) instead.

  • 3
    Brilliant - this isn't quite the answer but it got me there. It turned out that if I ignored the large warning asking for the source directory and just click install it all worked. So you pointed me in the right direction, even if it was just-click-the-button rather than fix-your-DNS that was the key! Doh
    – dumbledad
    Commented Jul 28, 2014 at 16:48

If you're coming here in October 2014, you might just need to go to Windows Update on the VM and install the fix for this issue. It seems like a recent security fix broke the ability to install 3.5.

  • 2
    Any update on the update number/reference for this fix?
    – Doug
    Commented Oct 29, 2014 at 6:06

In my case, even with unrestricted internet access I could not install any roles or features. This turned out to be because I have policy setting windows updates to come from an internal WSUS server IP, which does not include the source files for Server 2012 R2 roles and features. To fix this set the alternate sources policy:

  1. In Local Group Policy Editor or Group Policy Management Console, open the following policy setting. Computer Configuration\Administrative Templates\System\Specify settings for optional component installation and component repair
  2. Select Enabled to enable the policy setting, if it is not already enabled.
  3. If the computers that are controlled by this policy setting typically receive updates through WSUS, but you prefer to go through Windows Update and not WSUS to find missing feature files, select Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS).

This setting will work for any role and feature, not just .NET 3.5


Add-WindowsFeature NET-Framework-Core (from http://msdn.microsoft.com/en-us/library/dn169001(v=nav.70).aspx#InstallNET35) worked for me

  • 1
    Essential part of the answer is included: Add-WindowsFeature NET-Framework-Core.
    – Jussi Palo
    Commented Nov 6, 2014 at 10:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .