4

I have a Dell Inspiron 15 3537 laptop. As you know, we use 'alt+arrow key' to navigate forward or backward in a web browser, file explorer, etc. Now my left 'alt' key is working in this very manner. But my right 'alt' key would rotate my display when used with an arrow key. So I searched on the internet and disabled the 'hotkeys' from 'Graphics Options' under 'Intel HD Graphics Control Panel'.

Now all is fine other than that the right 'alt' key doesn't work. It won't even highlight the menu bar as the left key does. Nor would it navigate as mentioned above.

I can assure you that the right 'alt' key is working (as it does rotate the screen). Does anyone know how to make this right 'alt' key which has been rendered useless, work as normal?

Thanks!

  • If all else fails, you should be able to write a simple AutoHotKey script that gives you back the missing functionality. – Cfinley Jul 28 '14 at 18:48
  • @Cfinley Could you tell me how that works? – Russell Crowe Jul 28 '14 at 19:30
  • I went ahead and just wrote an answer for you. Let me know if you have any questions about it. – Cfinley Jul 28 '14 at 19:59
0

AutoHotKey is a downloadable program designed to automate your computer via scripting. It basically allows you to create keyboard shortcuts for anything. It can also remap keys. In your case, we will remap your Right Alt key to be a Left Alt key.

First, download and install the program from the link above. Once installed, find a place where you would like to store the script (C:\Users\{user}\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup is a good place, as they should start with Windows) and right click on empty space in Windows Explorer -> New -> AutoHotKey Script. Name it anything you like. Right click the new file and hit Edit Script and paste the following:

RAlt::LAlt

Save the file, close, and double click the file to run. This looks for the right alt key press and sends a left alt key press.

You might also want to check out questions tagged with AutoHotKey on Super User and Stack Overflow.

  • I did exactly as you said, and it still doesn't work. The sample hotkey provided by the program works fine though. Any solution? – Russell Crowe Jul 29 '14 at 17:49
  • Maybe '!' isn't invoking the right alt key yet. Infact, when I try this script: "!Left::Browswer_Forward", even the left alt key doesn't respond to the script. – Russell Crowe Jul 29 '14 at 17:52
  • @RussellCrowe Try '#' instead of '!' just to see if that works. That is the Windows key. – Cfinley Jul 29 '14 at 17:53
  • Nope, still nothing! It just repositions my window. – Russell Crowe Jul 29 '14 at 17:54
  • @RussellCrowe So it appears that I misunderstood your question. What happens if you use RAlt::LAlt instead? Basically remaps your right alt to your left alt. – Cfinley Jul 29 '14 at 18:04
5

You might not need AutoHotkey to solve this problem. I had the same issue in Windows8.1 - my right alt was working (causing screen rotation), but it was not working like the left alt key. In my case, I had to change a simple Windows setting to fix this.

This was because of a non-standard keyboard layout as explained here: https://support.microsoft.com/en-us/kb/82202

When you run Microsoft Windows in real (3.0 only), standard, or 386 enhanced mode with the US-International keyboard layout, the right ALT key functions differently or not at all.

With the US-International keyboard layout, the right ALT key is remapped for international functionality. The left ALT key can (and should) be used for Windows commands.

Apparently Windows does this intentionally if you set your region to anything outside of the US. In my case, I had set it to India, so my language and regional options and most importantly, keyboard layout had been set to English (India).

Using this as a guide, I had to simply change my language preferences to use English (United States) instead of English (India). This set my keyboard layout to "US" and this immediately made both left and right alt keys work identically. Problem solved.

1

For Windows 10 users, Goto "Windows\Settings\Time & Language\Region & Language\", under 'Languages' section click the language whichever is already there, click 'Options', then 'Add a keyboard' and select 'US QWERTY'. This worked for me. Hope it helps!

0

You can use Autohotkey to remap the Alt key to LAlt:

#SingleInstance force
^>!*::LAlt

Dont forget to give that Script in your autostart folder

Description:

  • ^= on key press not release
  • >=right side
  • ^= on key press not release
  • !=alt key
  • *= and all other keys
  • ::=remap to
  • LAlt= left Alt key
  • Welcome to superuser: While this may or may not answer the question,(an answer has been accepted) it would be a better your answer is better suited or when to do something with your answer plus easy to follow instructions. If you feel your answer is best do these things, add more detail and reedit. Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Nov 2 '16 at 19:09
-1

you need to change the keyboard layout to English US

heres how -

Go to Control Panel -> Language -> Add language ->English United States ->

Then to select the the keyboard Language you can use windows key + space . I had a keyboad language shortcut next to my Notification and TIme (in my taskbar on the right), so i just selected it from there...

Hopes this helps,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.