I am trying to boot Ubuntu 12.04 a Samsung ATIV book 8 laptop. Samsung ATIV book 8 came with Windows 7. I am successfully able to install Linux Ubuntu 12.04 on the SSD using USB pen drive which has erased Windows 7. But when I go to the UEFI configuration, I am not able to select the SSD, it has disappeared after installing Linux on SSD and and the options are blank, no boot device options. I tried different combinations of changing the following boot options:

  • Secure boot control
  • OS mode selection
  • Fast BIOS mode

But it doesn't give back the SSD option to boot.


It seems that you need to install Ubuntu in UEFI mode.

To install Ubuntu in EFI mode:

Use a 64bit disk of Ubuntu (Ubuntu32bit cannot be easily installed in UEFI mode)

You might want to use an EFI-only image to avoid troubles with mistakenly booting the image and installing Ubuntu in BIOS mode.

Use a supported version of Ubuntu. Support for UEFI appeared in 11.10, but has become more reliable in next versions. Support for UEFI SecureBoot appeared in 12.10 and 12.04.2.

Set up your firmware (BIOS) to boot the disk in UEFI mode (see the "Identifying if the computer boots the HDD in EFI mode" paragraph below) [...] Identifying if the computer boots the HDD in EFI mode

This is possible only if you have already installed Ubuntu on the HDD, or by looking at the BIOS setup (see paragraph below).

From an Ubuntu installed on the HDD (neither liveCD nor liveUSB), open a terminal (Ctrl+Alt+T), then type the following command:

[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"

Remark: if the result is "Legacy boot on HDD", then either the BIOS is not UEFI type, or the BIOS is not set up to boot the HDD in UEFI mode.

Identifying if the computer boots the Ubuntu DVD in EFI mode

Warning: even if your PC boots the DVD in EFI mode, it might boot the HDD in Legacy mode (and the contrary).

When booting on a 64-bit Ubuntu disk:

  • If the BIOS is set up to boot the CD in EFI mode, then you will see the screen below:


  • If the BIOS is NOT set up to boot the CD in EFI mode, or if the disk is not 64-bit, then you will see the screen below:


Set up the BIOS in EFI or Legacy mode

Some recent computers (>2011) allow to set up the boot either in UEFI mode or in Legacy (not-EFI) mode. The way to carry out this setting depends on the computers, but generally this setting is located in the "Boot order" tab of the BIOS (to access the BIOS screens, it is generally necessary to press a key during the PC startup).

Note: Some BIOSes (e.g. American Megatrends' "Aptio", found on the Asus vivobook series) call Legacy mode "Compatibility Support Module" or simply "CSM".

Remark: Some BIOSes allow one to set up the boot mode for the optical drive separately from the boot mode for the HDD.

For example, below:

the "UEFI Hitachi" line allows to boot the HDD in EFI mode,
the "P1: Hitachi" line allows to boot the HDD in Legacy (not-EFI) mode,
the "P3: DVD" line allows to boot the Ubuntu CD in Legacy mode
the "UEFI: USB" line allows to boot the Ubuntu liveUSB in EFI mode. 


Here is a 2nd example of BIOS, simpler, where the "Boot Mode" parameter allows one to choose the boot mode ("UEFI" or "Legacy") for all media (hard disk, CD, USB...) at the same time.


Some other firmwares (BIOSes) propose an "UEFI/Legacy Boot:" option with the following choices: [Legacy only], [UEFI only] and [Both]. This last one boots in EFI mode when possible, then in Legacy mode if no EFI files are detected.

Creating an EFI partition

If you are manually partitioning your disk in the Ubuntu installer, you need to make sure you have an EFI partition set up.

If your disk already contains an EFI partition (eg if your computer had Windows8 preinstalled), it can be used for Ubuntu too. Do not format it. It is strongly recommended to have only 1 EFI partition per disk.

An EFI partition can be created via a recent version of GParted (the Gparted version included in the 12.04 disk is OK), and must have the following attributes:

    Mount point: /boot/efi (remark: no need to set this mount point when using the manual partitioning, the Ubuntu installer will detect it automatically)

    Size: minimum 100Mib. 200MiB recommended.

    Type: FAT32

    Other: needs a "boot" flag.
  • Ok. So I did following still no success. Set the Secure Boot Control to OFF – user2836943 Jul 30 '14 at 2:48
  • Ok. So I did following still no success. (Now the SSD has only Ubuntu which was installed previously, no Windows OS) Insert USB pen drive with Ubuntu 12.04.3 64 bit Set the Secure Boot Control to OFF OS Mode Selection to UEFI OS Fast BIOS Mode set to OFF Set the Boot priority to USB. Now the laptop boots with Ubuntu from USB. And I see the 3 option menu. I selected try Ubuntu. And then installed Ubuntu as usual into SSD. Reboot the system. But now when I go to BIOS config. I don't see SSD as boot device priority. How can I solve this ? Am I missing something ? Thanks. – user2836943 Jul 30 '14 at 2:54
  • @user2836943 Does the SSD have an EFI partition on it? – YtvwlD Jul 30 '14 at 7:20
  • I haven't created any partitions. Its brand new laptop which came with Windows 7. So when I installed Ubuntu, I chose erase Windows 7. So I think SSD doesn't have any partition. Not sure about EFI. How do I check ? – user2836943 Jul 30 '14 at 8:08
  • @user2836943 Boot from a live cd (or usb stick) - important: boot in EFI mode - and run sudo parted /dev/sda print. – YtvwlD Jul 30 '14 at 10:11

Finally I was able to install Ubuntu with following boot options: CSM mode
Secure boot OFF
Fast boot OFF

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.