I’m a developer; I basically work in a Windows 8 environment with several virtual machines running Linux, Windows, etc.

I want to prevent Windows associating new file extensions. That is, if I want to open a file Read.me (from a Linux environment) I want to be able to open it with Wordpad or Notepad but I do not want Windows to associate the extension .me with Wordpad or Notepad.

How can I

  1. always have Notepad and/or Wordpad available on the right-click “open with” menu?
  2. stop Windows from automatically associating the file extension with the selected program.

I need something simple and non-intrusive, with no side effects. And I do not want to use external programs such as Notepad++. I want to use Notepad and/or Wordpad, as I said. Keep it within the Windows 8 operating system.

  • 2
    Software like Notepad++ puts "Edit with Notepad++" by default on right click menu Jul 29 '14 at 10:26
  • 1
    I want to do this within the OS; I do not use Notepad++; I want Microsoft solving my anxiety every time they decide to add a new association.
    – Pat
    Jul 29 '14 at 11:44

You can use a registry hack to add an Open with Notepad option in the right-click menu for all files, without affecting file associations. This is similar to what Notepad++ does when it is installed, except you don't need to install anything.

  1. Press Win + R to open the Run dialog.

  2. Type regedit and press Enter

  3. Navigate to HKEY_CLASSES_ROOT\*\shell

  4. Right-click on shell

  5. Choose to create a new key, calling it Open with Notepad or something similar

  6. Create a new key below that one called command

  7. Double-click on the (Default) value in the right-hand pane and enter the following:

    notepad.exe %1

  8. The new option should appear in the context menus straight away without needing a restart

If you wanted to you could repeat the same steps but for Wordpad instead of Notepad.

This is based on this article from How-To Geek which was originally written for Windows Vista but seems to work for Windows 8.

  • This is definitely a step in the right direction. What I'd really like better it's just adding Notepad and Wordpad as always available options for "Open Width". "Open Width" is controlled somehow by that evil MS extension engine. I'm looking for that info. I also want to stop/control the association mechanism.
    – Pat
    Jul 29 '14 at 12:32
  • For me, Notepad and Wordpad appear in the list of programs in the Open With dialog. If you manually pick an application by clicking More options then Look for another app on this PC then the application will be shown in the list whenever you click the More options link. However, the issue seems to be that after doing this once, Windows will no longer show the Use this application for all .blah files checkbox. Once a file has an association you can use the Open with menu option further down to manually pick a program. It will then keep track of which programs you have used.
    – James P
    Jul 29 '14 at 13:11
  • it is not like that. Wordpad and Notepad appear after the MS engine already "worked" on that extension. i.e. if you have a file w/o extension you do not get the Wordpad/Notepad options. Besides that if you use i.e. Notepad on an new extension without checking the association check box that's the last time you see that checking box; next time you click on that extension the option for no association is now gone and you are screwed (the association is created)...
    – Pat
    Jul 29 '14 at 13:34
  • @James, Why are the other context menus like "Notepad++" and "7Zip" not listed under HKEY_CLASSES_ROOT\*\shell?
    – Pacerier
    Apr 11 '15 at 8:41

If you open the file from inside Notepad it won't be associated (File -> Open in the menu bar). Also have a look at the video demonstration on youtube.

  • I open millions of configuration files, and other files I do not even know anything about its content. Do you consider practical opening Notepad then do an File/Open? there must be something better.
    – Pat
    Jul 29 '14 at 11:47
  • @Pat, I don't quite understand your comment. Why is it not practical? Just do a Win+R type in notepad and then type Ctrl-O.
    – Pacerier
    Apr 11 '15 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.