0

Lately I've noticed that my GNU/Linux Gentoo desktop computer turns itself on sporadically while it is suspended in ACPI S3 mode.

I have made no changes nor updates to the BIOS.

In dmesg I see the following whenever this happens:

[108014.336259] floppy0: floppy timeout called
[108014.336301] PM: resume of devices complete after 10861.842 msecs
[108014.336559] hub 8-0:1.0: state 7 ports 6 chg 0000 evt 0000
[108014.336562] hub 7-0:1.0: state 7 ports 6 chg 0000 evt 0000
[108014.336565] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0000
[108014.336567] hub 4-0:1.0: state 7 ports 2 chg 0000 evt 0000
[108014.336569] hub 3-0:1.0: state 7 ports 2 chg 0000 evt 0000
[108014.336572] hub 1-0:1.0: state 7 ports 2 chg 0000 evt 0000
[108014.336574] hub 7-5:1.0: state 7 ports 4 chg 0008 evt 0008
[108014.338301] hub 7-5:1.0: port 3, status 0503, change 0000, 480 Mb/s
[108014.338307] hub 6-0:1.0: state 7 ports 2 chg 0006 evt 0000
[108014.338323] hub 6-0:1.0: port 1, status 0103, change 0000, 12 Mb/s
[108014.338334] hub 6-0:1.0: port 2, status 0303, change 0000, 1.5 Mb/s
[108014.338338] hub 5-0:1.0: state 7 ports 2 chg 0004 evt 0004
[108014.338350] hub 5-0:1.0: port 2, status 0103, change 0000, 12 Mb/s
[108014.336504] Restarting tasks ... done.
[108015.348192] uhci_hcd 0000:00:1d.2: reserve dev 2 ep81-INT, period 1, phase 0, 17 us

There is nothing interesting in the syslog.

What is causing this? How can I determine what is causing this?

0

You can try to disable all wake up events for ACPI S3 in BIOS settings:

USB wake up from S3 [Disabled] (was enabled prior to this post)

Modem Ring Resume [Disabled]

PME Event wake up [Disabled]

HPET Support [Disabled] (High Precision Event Timer, was enabled prior to this post)

Power on by Mouse [Disabled]

Power on by Keyboard [Disabled]

AC Back Function [Disabled]

Power on by Alarm [Disabled]

  • These are unfortunately all disabled and have been so since the system was new. However HPET I'm not sure is even possible to toggle in the BIOS, it is compiled in support for this in my kernel, but I don't see how it would be related to such an uncontrolled wake-up event. – AttributedTensorField Aug 1 '14 at 14:05
0

The solution in my case appears to be to disable USB wakeup events in /proc/acpi/wakeup

In this file, I noticed that several USB devices had its state "enabled". Setting these to "disabled" by simply echoing the name into the file has prevented the issue from reoccurring so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.