I have Windows 8.1 running the OneDrive app, and whenever I make updates to any files in my OneDrive folder, attempts to right click any folder/file in the OneDrive directory are frequently met with the context menu showing up only to disappear milliseconds later.

This only seems to happen within the OneDrive directory. I tried disabling the OneDrive context menu shell extension to no avail. Any other suggestions?

  • Happens to me too. The solution is called "Dropbox".
    – joelmdev
    Oct 21, 2014 at 16:15
  • 1
    The solution is NOT Dropbox. A) I get 1TB with OneDrive B) I switched to OneDrive because dropbox kept locking my visual studio files during builds causing errors.
    – Chris
    Oct 21, 2014 at 17:57
  • I had similar problems with Dropbox but they were rare- only occurs when dropbox is syncing a file that needs to be changed during build. I've got 100GB with Onedrive. They could give me 100PB and it wouldn't matter as Microsoft is doing a crap job with the core purpose of the product, which is to sync files. But I digress... I've heard that the issue can be caused by multiple services trying to change the icon overlays. Do you have Tortoise[Git|SVN] installed?
    – joelmdev
    Nov 7, 2014 at 0:22

2 Answers 2


The problem appears to be with "OneDrive Sync Engine Host". Apparently is is constantly atteempting to sync even when there are no changes and when it does, for some reason it kills the right click menu.

Now here's where things get weird. If I go to the process and kill it. The problem goes away. Then if I go to OneDrive and right click it and choose "sync", it relaunches the OneDrive Sync Engine Host but the problem no longer happens. Instead, explorer itself seems a bit sluggish but at least I can get things done.


You'll be able to disable the OneDrive context menu shell extension using Sysinternal's Autoruns utility.

Once you've downloaded the utility and opened it, you'll be able to see everything that start's up automatically on your machine including your context menu shell extensions.

Browse to the Explorer tab and you should find an entry for OneDrive listed under any registry key that has the word ContextMenuHandler in it. For now untick it to disable the autorun point (the advantage of disabling over deleting is that you can reenable if you need to or if didn't work). Close Autoruns (no need to save) and give the machine a restart.

If that shell extension was the root cause of that context menu acting like that then you should now be able to right-click again in your OneDrive folder.

  • I already tried that and noted such in my second paragraph.
    – Chris
    Aug 7, 2014 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .