4

First of all, I don't like sounds (because I play a lot of media), therefore I have all system sounds disabled. However, whenever I'm using Remote Desktop (with the remote system muted), I get beeping sounds coming through my stereo.

For example, while using RDP, if I'm in some text editor with pages of text, and I scroll up really fast to the top, the smooth-scroll still has some work to do although it's already at the top. So instead of just stopping the scrolling, it seems RDP decides to make repeated beep sounds (although remote PC is muted).

This started happening in the past few months or so, it must have been a result of some update. Both systems run Windows 7 Ultimate.

How can I stop this from beeping?

2

Disable the driver on your remote machine to disable this annoying beep sound.

This didn't work for me because the remote machine 2008R2 doesn't have the driver referred to in another answer.

This helps:

  1. On remote machine: Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableBeep, and then press ENTER.
  5. Right-click DisableBeep, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Reboot remote machine - Do not only "re"-Login
  • ah thanks, that works on 2008, i was short of a nervous brake down before this – veritaS Jan 20 '17 at 19:42
1

The following article proposed a promising solution: http://blog.laksha.net/2009/08/remote-desktop-disable-annoying-beep.html

  1. open Computer Management
  2. select Device Manager
  3. make sure "show hidden devices" is checked (under the "More Actions" menu
  4. Under "Non-Plug and Play Drivers", disable the "Beep" item
-1

There's a setting in Remote Desktop (pre-connection) to "play remote sounds on this computer" or something similar. I've found that this doesn't always work and could be part of your problem. Uncheck this and try again.

Or just turn down your stereo... ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.