I have small local network with no access to internet. I was using PCs with win 7 OS and everything worked fine. But when I wanted to add PC with win 8 OS this PC can't see any other on the network. All other PCs are set to public network with ip 10.0.0.xxx. I did the same with win 8 PC, turned on network discovery, turned off password protection, allowed remote assistance even turned off firewall to PC but I still cannot see any other computer although it shows that is connected.

  • What happens if you try pinging each of the Windows 7 computers? (open a command prompt, and type ping [ip address] for example ping Try pinging them all then report back with your results. – smashingly Jul 31 '14 at 8:23
  • When I tried to ping it it gave Reply from destination host unreachable. It sows 4 packages sent, 4 received, 0 lost. I have checked and this Ip its showing is set as autoconfigured ipv4 address. It also has subnet mask while ipv4 address that I have configured is set to and – user2880783 Jul 31 '14 at 8:29

It sounds as though your Windows 8 machine does not have an IP address configured. 169.254.x.x is a special range of IP addresses used when an interface is set to auto-configure but no DHCP server was found on the network. Given you have no internet router, I'm guessing you have no DHCP server on the network, and you mentioned that your other computers are set to 10.0.0.x - this must mean they are configured with static IP addresses. Check the IP address config on your Windows 8 machine, and set a static IP address on the same subnet as your other computers (i.e. anything between and, but make sure you don't an IP address already in use by one of the Windows 7 computers). Use the command-line ipconfig /a to view the IP settings on each computer (especially the Windows 8 one).

  • I have set static ip address. Now when I checked using ipconfig it shows me that autoconfigured ipv4 address is preferred address and the one I have set up (10.0.0.xxx) is duplicate. Is there any way to remove autoconfigured ipv4? – user2880783 Jul 31 '14 at 9:05
  • The first thing you should try, is setting a different static IP address. When you configure your IP address, Windows checks to ensure that IP address is not already in use on the local network. It sounds like you've configured the same IP address on another machine, and I think Windows copes with this by "falling back" to autoconfigure. – smashingly Aug 7 '14 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.