1

I was updating my system (Debian Sid x64) using apt-get, but I got the following error:

Setting up fuse (2.9.3-14) ...
dpkg: error processing package fuse (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fuse

I had an error like this before (also with fuse), but then there was some information about the error displayed so I could do some research. There's nothing in /var/log/syslog or /var/log/apt/term.log.

Last time it was solved by updating the kernel, but I would prefer not to update the kernel at the moment without any prove that updating the kernel solves the problem.

Is there any way I can actually see what's causing the error instead of a message that just says it failed to install?

3
  • What happens if you try apt-get install --only-upgrade fuse? Do you get the same message?
    – jimm-cl
    Jul 31 '14 at 15:20
  • I get fuse is already the newest version., then 1 not fully installed or removed. and then I get the same messsage again. Jul 31 '14 at 15:25
  • 2
    I'm getting this too (Only slightly less annoying than not being able to upgrade my Xserver cause of the nvidia drivers...) the error is being triggered by this line in /var/lib/dpkg/info/fuse.postinst: udevadm test -e -p $(udevadm info -q path -n /dev/fuse) > /dev/null 2>&1 I have no idea what this is supposed to do but it's exiting with 1 and that's causing the issue...
    – J V
    Jul 31 '14 at 16:03
3

It seems that line 20 in /var/lib/dpkg/info/fuse.postinst has a syntax error. According to this the -e should be changed to -a. I did that and finally installed on my test VM.

So

udevadm test -e -p  $(udevadm info -q path -n /dev/fuse) > /dev/null 2>&1

Becomes

udevadm test -a -p  $(udevadm info -q path -n /dev/fuse) > /dev/null 2>&1
0

Simple solution:

mkdir /dev/fuse
chmod 777 /dev/fuse

apt-get install fuse
2
  • Welcome to Super User. Your answer could benefit from more detail. Please edit it to explain how your solution works/how it addresses the OPs question. Apr 30 '17 at 0:38
  • I don't see why this answer was downvoted. It solved the problem perfectly. I first checked the udevadm test -a line, and it was fine. Simply creating the directory with the right perms fixed the problem and fuse installed without problem.
    – Scott
    Jul 28 '17 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.