1

I've just been given some used HDDs from my friends. Two of them are Segate HDDs which have potential problem known as "Deathgate". All Internet articles say "Update the firmware", so I followed them. However, all my tries failed.

Here's what I've tried:

  1. Checked serial number and firmware revision with 'Drive Detect' which can be downloaded from Seagate - Determine Drive Configuration.

    Result:

    Seagate Drive Detect
    You can see that two HDDs whose serial numbers are ST3320813AS.

  2. Downloaded .exe from Firmware Update for ST31500341AS, ST31000333AS, ST3640323AS, ST3640623AS, ST3320613AS, ST3320813AS, ST3160813AS and it failed:

    Seagate Firmware Update Setup

  3. So, I followed the direction in error message. I downloaded ISO from same page and burned it into a CD. I booted with burned CD and followed the instruction but failed, again:

    Seagate Firmware Update CD

    If I press any key, it will just shutdown the computer. Also, 'Scan ATA device' menu didn't work. It just failed with some kind of error message like 'No controller'. If you need the exact message when failed in scanning, I'll take it and upload it.

    I also tried when unplugged all SSD/HDD except one deathgate HDD but I got same result.

How can I do to update the firmware? FYI, my mainboard is ASUS B75M-PLUS. If you need any information to find the resolution, please let me know.

4
  • Did you try to switch back the SATA controller from AHCI to IDE mode before booting on the CD? – Sacha K Jul 31 '14 at 15:57
  • Scan ATA Devices is not working because you don't have an ATA controller. I also suspect the reason the firmware upload is failing is because of the mode the SATA controller is being booted into. – Ramhound Jul 31 '14 at 16:02
  • IDE mode worked!! Thank you! Why don't you post it as an answer? – xylosper Jul 31 '14 at 16:14
  • @xylosper - I will. I can also explain the behavior. I made a mistake when I said you don't have a ATA controller, you do, technically its a SATA controller and the software in question only supports IDE mode. This wasn't clear until I view one of Seagate's own screenshots. – Ramhound Jul 31 '14 at 18:00
3

Go in the BIOS and switch back the SATA controller from AHCI to IDE mode before booting on the CD.

AHCI mode is "recent" and allows to use advanced SATA features (like hot swap and command queuing), it's supported out of the box only since Vista. When you boot from that CD it's only supporting the "historical" IDE mode.

1
  • In my case, I had to set in the BIOS the RAID MODE (options that only appears when On-Chip SATA Controller is Enabled) to AHCI (It was in IDE, and I had to revert it back to IDE after updating the firmware). – Forestrf Jun 21 '19 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.