8

I have a pair of Bluetooth 4.0 headphones which are paired with both my laptop and my desktop. As soon as I power on the headphones, they will wake any paired device from standby. So if I have my desktop in standby and I want to use the headphones with my laptop, they will wake my desktop from sleep and reconnect to it.

I would like to be able to disable this functionality. If I view the power settings on the Bluetooth module in Device Manager, the option to "Allow this device to wake the computer" is grayed out. This is probably because the Bluetooth adapter in my desktop is powered by USB, and, per Microsoft's implementation of the Bluetooth protocol, the USB root hub and controller handles the power states for connected devices.

However, if I open up the root hub to which the bluetooth module is connected, the option to "Allow this device to wake the computer" is also grayed out. I don't want to disable it here, anyway, since my keyboard is also connected to the same hub and I want to be able to wake my computer from standby with my keyboard.

Using the PowerCFG -lastwake command in a command prompt only tells me that the device that woke the computer was the USB Root Hub (as it should be, per Microsoft's implementation of the Bluetooth protocol). Right now, when I put my computer to sleep, the Bluetooth adapter enters a D2 sleep state. Is there a way to force it into a D3 (off) state when I put my computer in standby? Or a hack in the registry or somewhere that will disable the wake from standby functionality for the Bluetooth adapter?

How do I prevent my computer from waking from standby whenever I power on my Bluetooth headphones?

:Edit:

powercfg -devicequery wake_programmable
HID Keyboard Device
HID-compliant consumer control device (001)
HID Keyboard Device (001)
HID-compliant system controller (001)
HID-compliant consumer control device (004)
HID-compliant system controller (003)
HID-compliant consumer control device (005)
Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
HID-compliant vendor-defined device (006)
HID-compliant vendor-defined device (008)
HID-compliant vendor-defined device (009) 
HID-compliant vendor-defined device (010)
HID-compliant mouse (001)

powercfg -devicequery wake_armed
HID Keyboard Device
HID Keyboard Device (001)
HID-compliant mouse (001)
8
  • 1
    Run the following command and post here the output: powercfg -devicequery wake_programmable & powercfg -devicequery wake_armed Do you get the same issue if you disable all power management options (i.e. you clear the Allow the computer to turn off this device to save power check box)?
    – and31415
    Aug 1, 2014 at 7:57
  • @and31415 I've updated the question with the results of the commands you requested. I've done some testing, and unchecking the Allow the computer... checkbox does appear to prevent the computer from waking when I power on the headphones - which seems completely backwards, but I'll take it. Unfortunately, this has the side effect of increasing my power consumption (marginally, but still). Barring any other suggestions, if you post it as an answer I'm willing to accept it. I'll give it a couple days of use, though, just to be sure.
    – Thomas
    Aug 2, 2014 at 4:33
  • If the Bluetooth adapter is attached via USB, the simplest answer is to disconnect the adapter when you're not using it. I have to do the same thing with the mouse for my laptop when I put it to sleep - the slightest bump against the desk (which I occasionally do in my sleep) will wake the system if I don't.
    – Iszi
    Aug 20, 2014 at 15:27
  • @Iszi - Well, it's a bit late, but going back in time... in this case the Bluetooth adapter was part of a PCIe WiFi NIC. The WiFi card itself is a PCIe mini card on a PCIe standard adapter. Apparently PCIe standard slots don't natively support USB while PCIe mini slots do. This means the WiFi card requires a separate physical connection to a USB header to enable Bluetooth when used on the PCIe standard adapter. (Cause I guess it would cost too much to put a USB root hub controller on the adapter when they could just include a length of wire.)
    – Thomas
    Jul 28, 2019 at 19:42
  • Did you ever find solution @Thomas ?
    – Mike
    Jun 13, 2020 at 11:16

3 Answers 3

3

To see the list of wake-capable devices:

powercfg /devicequery wake_programmable

HID Keyboard Device
Intel(R) Dual Band Wireless-AC 8265

To see the list of wake-enabled devices:

powercfg -devicequery wake_armed

HID Keyboard Device

To disable awake from a certain device:

powercfg /devicedisablewake "HID Keyboard Device"

Et voilà:

powercfg /devicequery wake_armed

NONE
0
0

Would you consider this scenario:

  1. when Desktop PC standby time is reached, auto trigger a script that will disable bluetooth adapter, trigger async standby in 5 secs, window popup "Windows standby at hh:mm press OK to continue", script now paused.
  2. 5 secs later - Desktop PC goes into standby mode
  3. Desktop PC ignores all Bluetooth devices
  4. When you want to use laptop exit from standby state via non-Bluetooth device (eg laptop keyboard) and answer waiting popup, script continues and enables Bluetooth adapter
  5. Desktop PC resumes

Would that be suitable?

Here is standby_bt_ctl.cmd which would need to be hooked in (suggestions needed for that):

@echo %DBG% off
:: go to standby after turning off Bluetooth adapter
::
:: bt_ctl.cmd - still to be determined would suggest devcon tool
call bt_ctl.cmd off
start /min nircmd.exe cmdwait 5000 standby
nircmdc.exe show nircmd infobox "Standby at ~$currdate.dd-MM-yyyy$ ~$currtime.HH:mm:ss$" "Information"
call bt_ctl.cmd on
1
  • That wouldn't work as it is, since I never use standby timers, I always enter standby manually (instead of shutting down). I could modify the script and put a shortcut on my desktop for it. However, the comment above from and31415 regarding disabling power saving features on the adapter seems to have resolved the issue.
    – Thomas
    Sep 26, 2014 at 15:25
0

As comment section from the highest answer says, the root cause is that Bluetooth chip is integrated with WiFi chip, therefore when Bluetooth device trying to re-connect to computer when it was turned on, the computer will see that your network adapter is working, which is considered as Wake On LAN.

To solve this issue, go to Device Manager, find your WiFi adapter's property, uncheck the "Allow the computer to turn off this device to save power".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.