0

I've got a bit of a problem with Google Chrome. A few weeks ago I switched to another ISP that offered IPv6. Since then Chrome is randomly freezing when accessing certain websites (freezing as in "not responding" - at all, for 10-15 seconds). I was able to track it down to the IPv6 usage.

What I did:

  • Clearing my Cache
  • Disabled all add-ons
  • Created a new Chrome Profile

Nothing helped. I reactivated the add-ons and decided to turn off IPv6 since it was the only new thing in my network setup I could think of. I then cleared the cache and visited a website that I found to be especially prone to this kind of freezing (maxmind.com). Suddenly it was working fine. I could reload the page as often as I wanted to, no freezing anymore.

I turned IPv6 on, cleared the cache and visited the page again. It froze, Chrome was "not responding" for about 10 - 15 seconds while loading the page. After reloading multiple times, it froze again.

I tried this multiple times and to me it is clear that IPv6 is the problem. Now, I'm not too sure what to do about it or how to debug it. I'd report a bug to the Chromium team but found this one. It seems quite related to my issue, especially when looking at #5 ("Do you see the browser freeze for ~5 seconds every now and then?"). This report is quite old, however, and I'm not too sure whether it applies to my problem. I'd expect it to be a bit more popular if it affects IPv6 usage that much.

It doesn't happen on every page, only on some and not on every visit, although the example page causes it quite reliably.

If you've got any idea what I could do about this, I'd be very thankful.

  • You could try to change your DNS servers. – YtvwlD Aug 1 '14 at 10:28
  • I've tried, it didn't solve it. I decided to report a bug now: link – user40974 Aug 1 '14 at 11:16
0

If you have native IPv6 from your ISP, make sure that you disable all IPv6 tunneling technologies built into Windows. These can often cause problems as they are not always reliable, and in some circumstances could be used instead of your native service.

You can do this from a PowerShell or command prompt with:

netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled
netsh int teredo set state disabled

and restarting your computer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.