0

We had a virtual machine server setup for web, FTP was setup using Filezilla Server and all the ports were opened for PASV mode, which worked great for a number of months before suddenly without reason stopped working and dropped the connection as soon as the client requested to use PASV mode.

We scrapped this server in the end and we have since setup another server running IIS instead.

I again setup the PASV ports we wanted to use (5001-5005) and this was working fine for a couple weeks until today, and now the PASV mode has stopped working again. I've just opened a different set of ports (2501 - 2505) and set FTP to use this instead, but still the same issue. All firewalls and anti-viruses are disabled.

FileZilla client has this log:

Command: TYPE I

Response: 200 Type set to I.

Command: PASV

Error: Disconnected from server: ECONNABORTED - Connection aborted

Error: Failed to retrieve directory listing

Update:

Using ACTIVE mode from a client works fine. Just the component we're using with C# only works with PASV

0

I found out that the way that azure uses endpoints, is that if the port seems dead, then azure will stop forwarding on that port. Since the ports for PASV aren’t active until there is a FTP connection and PASV mode is started, azure will stop forwarding.

There is a work around for this which is to use Azure Powershell to setup the ports..

  • 1
    Could you provide more details or a link? – Matt Jenkins Apr 28 '16 at 9:13

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.