11

Hello yesterday i bought DELL Inspiron 15 (3542) win 8.1. And noticed that if charger is plugged on, screen becomes brighter, and after unplugging dimmer. Of course i tried adjust screen brightness, I've tried changing all power plan settings, changed advanced power settings to max. tryed go to bios but there was nothing about brightness. i tried use brightness buttons on keyboard no matter if charger is plugged in or not the bright bar is still set to full, however the bright difference still exist. the bright difference then charger is on are about 4%-6% . then i pull out the charger the screen becomes darken in few sec. and i noticed that after closing and opening the led(then computer is using only battery power) at the start screen is same bright as with charger plugged in. My sister have older Dell laptop(bought 4years ago) and for her the bright difference was about 50% but i repaired that through Bios. So how i can fix that uncomfortable issue?

4
  • 3
    Is it slowly dimming over a few seconds? Or just after a few seconds, immediately dropping into the new brightness? I'm trying to determine if you just haven't found the power savings settings, or if there is something wrong with the bulb/inverter.
    – Brad
    Aug 1, 2014 at 15:08
  • yap it is slowly dimming. its seems like there should be an option in settings. but i tryed all options few times. maybe there is some hiden options or so?
    – Gradex
    Aug 1, 2014 at 16:27
  • in the settings everything is maxed. it seems like then charger is plugged in, screen becomes like 5% brighter or so. but i checked all parameters.
    – Gradex
    Aug 1, 2014 at 16:49
  • I don't know if the newer Dells have this automatic dim smoothing, but the last few models I used didn't. Because of this, I suspect you actually have a voltage regulation problem. Something else to try... Drain the battery down until it is completely dead. Boot the laptop on AC power and check its brightness. With it on, plug in the battery and see if the screen dims at all.
    – Brad
    Aug 1, 2014 at 16:53

9 Answers 9

9

I know that this question is 2 years old, but this issue still pertains to this day, and might still be of relevance to some people. I'll be sharing a solution that I found. I'll guess that OP has a laptop with an AMD GPU/iGPU. Basically the graphics driver is causing the screen to dim. To fix this, right click your desktop, then (probably at the top of the menu), click 'AMD Catalyst Control Centre' Then, under 'Power', click 'PowerPlaytm'. Within the new menu that is brought up, look at the bottom where it says 'Enable Vari-Brighttm'. Untick it. Your problem should be solved, as was mine.

5
  • "I'll guess that OP has a laptop with an AMD GPU/iGPU" You guessed wrong. Why didn't you bother to checked the spec? "Graphics adapter NVIDIA GeForce 820M - 2048 MB". So your answer does not apply to the question.
    – DavidPostill
    Jun 6, 2016 at 22:19
  • I have amd and this does not work.
    – Dan Z
    Nov 15, 2016 at 3:50
  • It's working for me. In my case Windows Update installed the AMD drivers and it was causing the issue. Thank you Jul 14, 2020 at 18:00
  • It's working for me. In my case Windows Update installed the AMD drivers and it was causing the issue. Thank you Jul 14, 2020 at 18:00
  • This helped me with a brand new AMD-based Lenovo IdeaPad 5 - if you don't have the AMD Radeon Software installed, you'll need to install it in order to turn the 'VariBright' feature off.
    – M_M
    Jul 16, 2020 at 10:02
4

The computer is designed to do that when it's unplugged. You can change the behavior if you don't like it. This link should have everything you need.

http://www.eightforums.com/tutorials/5464-power-plan-settings-change-windows-8-a.html

3
  • 5
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Cfinley
    Aug 1, 2014 at 16:08
  • 2
    that was first things what i have done.:/ the bright difference is very low, but for my eye it is very uncomfortable.
    – Gradex
    Aug 1, 2014 at 16:38
  • Does not solve the problem.
    – Dan Z
    Nov 15, 2016 at 3:48
1

If you own a computer with amd graphics. You will have to disable "vari-bright"

1)go to amd radeon settings 2) go to advanced 3) energy/battery-> disable vari-bright

1
1

It's a very late answer but it could possibly help someone...

This is one of the complex problems which has irritated me for very long and I can guarantee that one who has not experienced the problem cannot understand it fully.

I first found this problem on my laptop (Dell 3543). The problem is when you start your laptop unplugged, the screen is very low in contrast and in addition to that the brightness changes dynamically based on the content it displays.

Some people call it Intel Display Power Saving Technology's Fault many confuse it with adaptive brightness but the real problem is related with the BIOS.

Few Working Solutions:-

  1. Uninstall Display Driver
  2. Update your BIOS

In my case however I re-installed an older bios from vendor.

0

I have the same issue but I solved this, here is instruction,

  1. right click on desktop and click Graphics Properties.
  2. click power
  3. click on battery
  4. click maximum performance and apply and done.

you will see the display will 100% bright.

Thanks, Hilal

1
  • 1
    Screen still dims.
    – Dan Z
    Nov 15, 2016 at 3:48
0

I had the same problem. I am using hp pavilion notebook and for the operating system, I'm using windows 10. It basically happens because of graphics driver. I have Intel HD graphics card as a built-in graphics card. On the Desktop, Right Click and go to the Graphics Properties option. Then go to the power option. As my screen was getting dimmer when on battery, I chose On Battery menu from the left side. Then choose maximum performance and make sure you disable "Display Power Saving Technology". I think this option is causing the issue. It solves the problem for me. Hopefully yours too. :)

1
  • Thanks - this method is working if anyone is using Intel HD graphics. Feb 20, 2021 at 20:54
0

Solved: click on battery icon at bottom of desktop, where time & date appears. after click go to more options on battery icon, then create your own plan by name PLAN 1 or PLAN 2 as you wish. then set all settings like battery, power and other option to NEVER. then click on next.

Now your laptop screen will not be dim if you unplug the charger.

1
  • Why bother repeating what was already stated in older answers? It did not help.
    – Daniel B
    Jul 15, 2017 at 8:06
-1

This is a problem with the current graphics settings. Try this,

Right click on Desktop → Select graphics properties → click on Power → Under left hand top side select On Battery → Under Graphics power plans Select Balanced Mode or Maximum Performance and Disable Display power Saving Technology.

thanks...

-1

I was looking for a solution for his also, for my laptop : TOSHIBA SATELLITE L50-B-14P running on Windows 10 Home. My laptop runs on an Intel HD Graphics 4400.

To resolve:

1) Go to Desktop

2) Right click on desktop

3) Select Graphics Properties (the Intel programme should boot up)

4) Select Power from the icons presented

5) In the left column, select "On Battery"

6) Ensure the setting is set to: - Maximum performance - DISABLE Power Saving Technology

7) Apply the setting, and see your screen bright up :)

Please note: your laptop run time might not be as long as it was in previous setting.

Note 2) If your intel HD control screen does not start at step 3, please ensure you have the same graphics card as me, and check if you have your drivers installed properly. Further, check intel website for the graphics control programme.

Not the answer you're looking for? Browse other questions tagged or ask your own question.