3

I have a samba share located on a Router USB storage DD-WRT V24 USB drive. I try to copy a file from a MAC OSX machine using Finder. Finder returns the following message: "can’t be copied because there isn’t enough free space." Even though there is plenty of space. Finder can read file from Samba share. Using Terminal, I can read AND write from and to the Samba Share. It looks like there is something about finder. All directories and files have permission "777" so permission should not be an issue. The share is "public" therefor guest access works fine. Using Ubuntu, Windows 7 file browsers, I can read and write files without any issue. Why Finder can't write file while terminal can?

EDIT (added information): This brand new 2TB USB drive used for the share has been formatted in EXT3 using Ubuntu Disk Manager. Finder Status bar shows "Zero Byte available" which is not true since there is almost 2TB available and I can copy files from terminal as well as Windows and ubuntu machines. Is there any incompatibility between Finder and Samba and or EXT3 format?

EDIT2: (more test result) User16081's comment gave me some test idea. I just connected the USB drive on Ubuntu Workstation instead of the DD-WRT router. Now I can copy from MAC Finder and Finder Status Bar shows a valid size "1.86 TB available". Looks like DD-WRT samba server has some kind of incompatibility with MAC OSX Finder. Any idea for a workaround?

Edit3: I used terminal with "df -h" to know the size of the mounted volume. I mounted the same USB drive on a Ubuntu machine and after on my DD-WRT router. I get a very different result. The size OSX terminal reports when mounted on Ubuntu is correct while, it reports only 20MB when mounted on DD-WRT. This is shown on the 2 last lines.

sh-mbp:~ sylvain$ df -h
Filesystem                             Size   Used  Avail Capacity   iused      ifree %iused  Mounted on
/dev/disk0s2                          698Gi  492Gi  206Gi    71% 128965572   53935402   71%   /
devfs                                 190Ki  190Ki    0Bi   100%       657          0  100%   /dev
map -hosts                              0Bi    0Bi    0Bi   100%         0          0  100%   /net
map auto_home                           0Bi    0Bi    0Bi   100%         0          0  100%   /home
/dev/disk1s2                           21Gi  2.9Gi   18Gi    14%    765283    4734707   14%   /Volumes/Projects
//sylvain@sylvain-desktop/dd-wrt_usb  1.8Ti   97Gi  1.7Ti     6%         0 18446744073709551615    0%   /Volumes/dd-wrt_usb
//GUEST:@dd-wrt/DD-WRT_Root            20Mi   20Mi    0Bi   100%         0 18446744073709551615    0%   /Volumes/DD-WRT_Root

EDIT 4 I ran a similar test from a Ubuntu Workstation. It turns out Ubuntu sees that the reported size does not make sense and report proper used space but unknown available space and accept to copy files.

This sounds like samba server on DD-WRT is not reporting disk size or available space properly. MAC OSX Finder decides it can't try copying files while Ubuntu tries it anyway. The problem sounds to be coming from DD-WRT samba server. Any idea how to solve this? I did look extensively on DD-WRT forum and no luck.

I found a YouTube Video where it shows an Asus router (I use TP-Link TL-WDR3600) with DD-WRT V24Sp2 like mine having the same drive size (2TB) shared and we see the proper available space displayed in Finder. Nothing special was done during configuration. Other than using a different router, his disk has HPFS/NTFS format instead of EXT3.

migrated from serverfault.com Aug 1 '14 at 15:20

This question came from our site for system and network administrators.

  • does the finder status bar show the free space available? (In Finder, go to View>Show Status Bar) – Joe T Jul 31 '14 at 22:26
  • From the root of the share, it shows "2 items, Zero bytes avaialble" eventhough, there are only 3.26 GB used from this brand new 2TB disk – Sylvain Huard Aug 1 '14 at 12:05
  • sonds like DD-WRT monts the drive read only and changes to read write if one enters the share via Terminal/ssh. maybe someone can test this out and proof it – konqui Nov 7 '14 at 6:54
1

I had this exact issue on my dd-wrt router with an attached Western Digital NTFS hard drive.

Double-check that under Services->NAS, File Sharing, the Path drop-down box under Shared listed is to the actual partition and not to the drive as a whole.

As an example, when I connected the hard drive, the web UI only showed "/mnt/" in the drop down box. I used that, and had the exact problem you reported.

When I went back to the UI to troubleshoot, I saw that there were two choices in the drop-down under Shares/Path, "/mnt/" and "/mnt/sda_part1". I changed the path to "/mnt/sda_part1", and now it works exactly as it should.

Hope this helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.