1

I have a Chromebook with Debian installed using Crouton. I've installed Steam, and I'm trying to get through all the dependencies and errors associated with such a hacky setup.

My latest error that I cannot seem to resolve is Direct Rendering. Steam is throwing an error at every boot regarding "Direct Rendering," and the client is crashing randomly. I have run a glxinfo | grep direct and Direct Rendering is set to No.

I've tried reinstalling the opengl mesa drivers, along with making sure there weren't any unresolved dependencies. I'm lost as to what to do now. Anybody have an idea?

0

For reference, I solved my problem by updating Ubuntu from 12.x.x to the latest 14-ish LTS version. Looks like the older versions did not support direct rendering by default..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.