2

My Windows Feature List under the Control Panel for Turning Windows Features on and off does not fill with a list of features. I just get a message: "Please wait."

I have tried a couple of solutions I found online:

One suggestion was to try the stand-alone Update Installer/System Update Readiness Tool. (Windows6.0-KB947821-v34-x86.msu)

I downloaded it for Vista 32 bit and ran it. It took about 20 minutes and installed successfully. I rebooted. This did not fix the problem. My Windows Features window is still empty and shows "Please wait."

There was also a possible solution involving this Installer. It creates a log file. Supposedly, if you go into the log file you can see errors that could not be fixed. You are supposed to be able to fix those in the Registry. I checked the log file for unfixed issues. I did not have any errors under the "Package Manifests and catalogs" section or any other section.

I recently ran a full Disk Check on my hard drive. I ran SFC/SCANNOW successfully. I still have the empty window with no list of features.

I can see the exe: C:\Windows\System32\OptionalFeatures.exe But, it just doesn’t seem to want to run.

  • I have seen this issue on other operating systems. I have had Vista since 2007 when I bought the laptop for an ASP.Net project. It has served me well. I never had any problems with it. Of course, I keep the updates current, always run a weekly virus scan, and keep the hard drive organized and as clean as possible. – Junco Aug 2 '14 at 16:43
  • 1
    Oh...Yeah...The issue described above...My next step appears to be to reinstall the operating system. I was hoping someone else had a different suggestion. – Junco Aug 2 '14 at 16:45
  • was sfc able to repair all files or did it still show any corrected files? – magicandre1981 Aug 2 '14 at 17:16
  • 1
    @rt.hawk - Is Windows Management Instrumentation service is running and set to start automatic? – Ĭsααc tիε βöss Aug 2 '14 at 21:05
  • Isaac: Thanks! This didn't solve my problem. It showed me what I was doing wrong. I looked up the Windows Management Instrumentation in my local services window. The explanation said that it is used to gather information about various things on my computer. That made a little light bulb go off in my head. I opened the Windows Feature List again and waited a couple of minutes. The list appears. Apparently, it just needs some time to get the info. Even though I'm a bit red-faced, I thought I'd leave this question up in case someone else has this issue in the future. Thanks to all who answered. – Junco Aug 3 '14 at 14:15
2

See Isaac the Boss's and my Comments. There is nothing wrong. I just needed to wait for the information to be gathered.

I thought I'd leave this question up instead of trying to delete it. Maybe someone else will run into this supposedly blank window issue.

Thank you to all who read and commented on this issue.

  • yes the feature list does take a while to load, but should take incredibly long. How long did you wait? – Keltari Aug 3 '14 at 15:25
  • It takes about 2 and a half minutes. – Junco Aug 3 '14 at 18:33
2
  1. run sfc /scannow
  2. check if Windows Modules Installer is set to automatic and running
  3. run "Windows System Update Readiness Tool"

That worked for me on 32 bit Win7 Ultimate machine.

0

To fix this I found this page: http://computerstepbystep.com/windows_modules_installer_service.html

Check Windows Modules Installer is started. On my computer it was not. I started it and the problem was solved.

/Glenn

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Dec 10 '16 at 12:32

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.