1

My church has two separate wireless networks, one called ChurchInternet which broadcasts on a 2.4 GHz frequency and another called ChurchAudio which broadcasts on a 5 GHz frequency. Both are broadcast by (separate) Linksys routers. ChurchInternet is connected to the Internet while ChurchAudio has no Internet connectivity and is used for connecting to the sound equipment (we have a nice new mixer). We don't want anyone connecting to the ChurchAudio (which is why it's separate), but we do allow people with the password to connect to ChurchInternet.

We've got a desktop computer running Windows 7 in the church that we would like to be able to connect to both. This computer has two separate USB wireless adapters.

One of the adapters is a little older than the other, and can only see 2.4 GHz networks. So I obviously want that one to connect to ChurchInternet. That first adapter is called Wireless Connection 13

The second (newer) adapter is capable of seeing both 2.4 GHz and 5 GHz networks. So that has to be the one to connect to the 5 GHz ChurchAudio network. That one is called Wireless Connection 5

Unfortunately, I can't seem to get it to work correctly — for two big reasons:

  1. By default, both adapters try to connect to ChurchInternet. This is obviously not desirable, but I don't know how to make it not do that by default. Here's what it looks like on start up:

    enter image description here

    And this is what ipconfig looks like on initial start up:

    enter image description here

    I blurred it out here but I can tell you that it gives itself two different sets of IP addresses for the same connection. This is bad and I don't want it to do that! I want it be smart enough to know that Wireless Connection 5 should connect to ChurchAudio instead.

  2. Even after I manually disconnect Wirless Connection 5 from ChurchInternet and then manually tell it connect to connect to ChurchAudio instead, I become unable to actually use the Internet, and I have no idea why. Everything at that point looks like it should be working — this is what I see in Windows Network & Sharing Center:

    enter image description here

    But that graphic is deceiving. Even though it says it has Internet access, and recognizes that the ChurchInternet network has Internet access, I can't actually connect to anything. Ping requests time out. Browser requests just get stuck on a blank screen before eventually dying. By all accounts, it seems like it's trying to reach the Internet through ChurchAudio while completely ignoring the fact that it's connected to ChurchInternet.

How do I get this working?

  • you might want to try manually setting the connection metric of Wireless Network Connection 13 to a lower value like 1. And set the metric of Wireless Network Connection 5 to a higher value like 10. Here's a screenshot: i.imgur.com/PBTiUSc.png – Vinayak Aug 3 '14 at 8:29
  • Additionally, refer to this answer and this HowToGeek article – Vinayak Aug 3 '14 at 8:33
  • Vinayak, the tip about changing the connection metric did the trick. If you want to type that into an answer, I'll accept it! – soapergem Aug 3 '14 at 16:47
1

Here's what has worked for me on several occasions:

Try setting the interface metric of Wireless Network Connection 13 to a low value like 1.
And set the metric of Wireless Network Connection 5 to a higher value like 10.

Here's how you do this:

  1. In the Run command box (Win+R), enter shell:ConnectionsFolder
  2. Select Wireless Network Connection 13 and press Alt+Enter
  3. In the Properties window that pops up, scroll down to find:
    Internet Protocol Version 4 (TCP/IPv4) and double click it.
  4. In the window that pops up, click the Advanced button and uncheck Automatic metric and set the interface metric to a low value like 1 and click OK.

Do the same thing with Wireless Network Connection 5 but set its interface metric to a higher value (like 10, for instance).

For further reference, take a look at this HowToGeek article or this SuperUser question.

0

Either it's windows being stuffy (Which you can't do anything about). Or you only have one wireless networking card. IF thats the case and you're on a desktop you can buy another card like these: http://www.amazon.com/b?node=13983711 if you're on a laptop there's nothing you can do short of extreme hardware mods.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.