What I have

  • Linksys WRT54GL with DD-WRT replacing the original firmware
  • Linksys is connected to the internet on the WAN port, standard stuff
  • 2 windows (7 and 8) desktop computers connected via the LAN ports (2/4 ports consumed)

What doesn't work

  • Any server application, running on a computer that is on a LAN port, isn't able to be connected to from inside my home network (eg: one computer is not able to ping or ssh to another if it is on a LAN port).
  • Update: doesn't seem to matter if this the client/server is wireless or LAN.

What works

  • internet on all machines, wireless and LAN connected
  • ARP. I am able to type arp -a after running ping ip-to-LAN-connect-computer and I see the MAC address added to my arp cache.
  • I can ping my router via ping and that works from both PC's.

Troubleshooting so far

  • windows firewall is off. AV firewalls are off.
  • Being able to ping/connect worked before when I had this router and these computers at another place about 5 months ago.
  • For DD-WRT settings... I did a setting reset. Then I set... SPI firewall: off

Here is my routing table:

Destination LAN NET, Subnet Mask    Gateway, Interface  LAN & WLAN
x.x.x.0      WAN
x.x.0.0      LAN & WLAN            x.x.x.x  WAN   

notes: omitted with real IP's with x.x.x.x for security

  • Gonna double check the firewall stuff again and also try with another, third device. Something is telling me that if ARP is resolving that the server must just be rejecting the delivered packets. Give me about 24 hours to look into that.
    – Zombies
    Aug 3, 2014 at 19:42
  • Almost sounds like the separate LAN ports are routing to one another rather than bridging. It is possible that one of your LAN ports is designated as DMZ (it would have a separate subnet and another set of firewall rules)? If you get a small switch, connect the switch to one of the DD-WRT ports and then put the machines on the switch does it work? Wireshark is your friend. Install it on the Windoze boxen and watch the traffic (filter on icmp).
    – ericx
    Aug 3, 2014 at 20:59
  • Make sure you connect to the internal IP, not the externap IP, and also, make sure the ip addresses are in the same scope. You seem to use 2 different scopes and I think they're conflicting. Look what IP addresses each computer gets. Are they in the same subnet? (aka 192.168.1.x ? If not, thats your problem.
    – LPChip
    Aug 3, 2014 at 21:22
  • @LPChip Yes all are in the same subnet, 192.168.1.x ...ie: If I run ipconfig on all of the windows PC's it will give me an ip addressed, assigned by DHCP from the router, in ththe 192.168.1.x range.
    – Zombies
    Aug 3, 2014 at 23:18
  • If ARP works but ping and other applications don't, it strongly points to some kind of firewall issue. What happens if you swap in a different router (borrow one from a friend)?
    – Barmar
    Aug 8, 2014 at 18:21

2 Answers 2


It sounds to me like your computers are sending icmp but not answering icmp. Ping replies on windows 7 are automatically allowed if port 445 is accessible.

You can confirm this by getting a fourth device and pinging to the router and both computers. Or by pinging from the router to the computers using the router interface.

  • Check the firewall settings on the router. Turn off the router firewall and disconnect it from the internet if you want for security reasons while you test ping.

    I am guessing your router is doing something such as:

Filter Internet NAT Redirection This feature uses port forwarding to block access to local servers from local networked computers. Select Filter Internet NAT Redirection to filter Internet NAT redirection. This feature is not selected by default


  • Try this if it exists. go to the Networking Properties of the connection from Control Panel\All Control Panel Items\Network and Sharing Center and turn off AGN Filter Interface (64-bit).

    • Check if you have installed any networking software from isp's for example and remove it.

    • It seems possible that something happened to both your computers at about the same time for them not to answer icmp. Try turning on your firewall again and explicitly re-enabling icmp. Check for redirected ports. Make sure the settings are permanent by closing the window and re-opening it.


I don't know if this could be the problem but it's better to mention it than to leave it out.

Make sure you have enabled Network Discovery.

  1. Click Start > Control Panel > Network and Sharing Center
  2. Click Change advanced sharing settings
  3. Enable Network Discovery

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .