5

I use XCode and other apps frequently. Suddenly 3 days ago, some of the shortcuts on my Macbook pro stopped working

Namely the Cmd + Shift + O, Cmd + Shift + R, Cmd + Shift + W when the Cmd and Shift are on the left side of the keyboard, when they are on the right side of the keyboard it works just fine.

On my other mac computer, they also work just fine. On an external keyboard they also work just fine

Cmd + any combo works just fine and Shift + any letter gives upper case letter as expected

Why isn't the combination left side Cmd + Shift + anything work anymore ?

Just to be clear, when I click that combination, the computer recognizes it as Cmd + anything , and does not see that I also pressed Shift

  • I was facing same issue with Cmd + Shift + R on OS X Sierra. I just had to press Fn as well to get it to work. – Sufian Aug 17 '17 at 11:04
2

First, check System Preferences > Keyboard > Keyboard Shortcuts to see if cmd-shift-N has been mapped to anything. Be sure to check all the system categories as well as Application Shortcuts > All Applications.

If that doesn't reveal the culprit, you might want to look to see if you have any "Input Manager hacks" installed. These are third-party tools that use a skanky method to modify the behavior of the system and other apps. Some of the best known Input Manager hacks include SIMBL (and tools that use SIMBL, such as Afloat) and APE (Unsanity's Application Enhancer, and related "Haxies"). If you find any input manager hacks, remove them according to their instructions.

  • I already read this answer somewhere else, this answer does not help, I've reset my keyboard preferences and killed all apps that i've installed in the past 2 weeks, and still nothing\ – Lena Bru Aug 5 '14 at 12:58
  • that solved it for me thanks! in my case it was the 'voila' app, basically I would look for anything that uses shortcuts – Robert Sinclair Jan 20 '17 at 16:24
1

Try to change keyboard language. As I use LT and EN, when it was on LT - nothing happend, so i've changed to EN - everything works just perfect :)

Regards, N.

0

I confirmed that on a mac laptops which was shipped to me from the UK the key bindings for shift+apple sometimes just didn't work properly. even after trying to :

  • restore defaults
  • upgrade entire os to yosemite

So rather than fight the lack of shift+command shortcutting, i simply went with A workaround , where I simply went into System Preferences -> and then I changed this shortcut entirely.

attached screenshot, removing the "shift" part from the command, this allows me to take screenshots using command+4, instead of shift+command+4

-2

Just had the same problem.I went to the screen shots menu then clicked on the wanted menu as if I would like to modify it, (for me that was the selected area one) then hit exactly the same combination, for that one it was cmd+shift+4, and then it worked nicely.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.