4

This question already has an answer here:

When trying to turn on Bitlocker on an external 4 TB USB HDD using Windows 7, there's error A device attached to the system is not functioning. in a rather unhelpful dialog, as shown below:

enter image description here

Now according to this question, there are a few solutions, but the answers aren't very detailed. First of all, the solution in this answer (uninstall KB2799926) is unlikely to work I suppose, because this is external drive and uninstalling that would disable using Bitlocker on it completely. And then answers lack an exact way to format the drive to the maximum capacity, if that's the only way on external drive. So I'm looking for a succinct answer to these:

  • Does uninstalling KB2799926 and then reinstalling it later work or not, with external drives?
  • What's the exact command/method to format the drive to maximum working capacity?
  • Other known-to-work ways to enable Bitlocker on the drive, like acquiring a Win8 PC to do it?

marked as duplicate by Community Sep 27 '16 at 18:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is the drive NTFS formatted? If you try to turn on BitLocker using the command-line interface you should get the exact error code. – and31415 Aug 4 '14 at 9:04
  • 1
    Hahaha, marked as a duplicate when that other question is referring to an internal drive, and the solution offered is to disable a hotfix which will disable BitLocker on external drives, exactly what this question is about. Do you people read things before marking as duplicate? – tbone Jan 14 '17 at 19:52
  • @and31415 "manage-bde -G: -pw" --> "ERROR: Invalid Syntax. -G: was not understood." Nice work as always Microsoft. – tbone Jan 17 '17 at 0:47
1

I run in a similar issue using a partition on my disk. I found out that my perfect 30g partition was too close to the next one. I had to shrink it by 18 MB (17 not working and about 18 working) to make BitLocker work. So of course it was not linked to any "driver" issue, just partition size and free space after the partition issue.

Now, 18MB might be a ratio and it is indicated BitLocker Drive Encryption in Windows 7: Frequently Asked Questions that the minimum size must be 64 MB (55 MB according to Why does BitLocker need a minimum volume size of 64 MB?)

Extract from technet.microsoft.com

BitLocker hardware and software requirements for data drives Requirement Description

The drive must be least 64 MB in size.

  • 1
    Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise, be sure you tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Sep 27 '16 at 8:15
  • @David Read that other question, they are not the same. – tbone Jan 14 '17 at 20:53
  • @Francois, how did you determine this is what you had to do? I have a Seagate 8TB external drive and am getting the same error, Google is turning up absolutely nothing on how to resolve this. – tbone Jan 14 '17 at 20:54
  • @tbone - I wasn't referring to the answer linked, but to another another by Francois that appears to have been deleted. – DavidPostill Jan 14 '17 at 21:18
  • @tbone I had the exact same Error message window on a smaller partition and resolved it by leaving a bigger gap between partitions, Now I did not try it on a 4 TB disk. The NTFS limit with default is 16 TB and Bitlocker follows filesystem limitation. In the absence of other explanation, I suggested it to be the raison (ie need to leave a gap after the partition to be encrypted) Regards – sysarchitek Jan 15 '17 at 23:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.