3

I'm trying to upgrade Internet Explorer my Windows 7 (x64) development VM from IE8 to IE11.

Both the online and offline installers fail with a bland error message:

enter image description here

The troubleshooter tells me nothing, but the IE11_main.log reveals:

00:04.524: INFO:    Download for KB2834140 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=303935 -> KB2834140_amd64.MSU.
00:04.540: INFO:    Waiting for 1 prerequisite downloads.
00:05.101: INFO:    Prerequisite download processes have completed. Starting Installation of 1 prerequisites.
00:05.117: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1A5E3.tmp\KB2834140\Windows6.1-KB2834140-v2-x64.cab /quiet /norestart
00:10.577: INFO:    Process exit code 0x00000000 (0) [The operation completed successfully. ]
00:10.577: INFO:    The neutral pack was successfully downloaded from the internet. Installation will continue using the downloaded package.
00:10.577: INFO:    Waiting for 0 language pack downloads.
00:10.593: INFO:    Language pack downloads completed. (exit code = 0xffffffff (4294967295)).
00:10.624: INFO:    No reboot logic message NrApiStart(0), lParam=0x004f2b78 returned 0x00000000.
00:11.170: INFO:    No reboot logic message NrApiScan(1), lParam=0x00000000 returned 0x00000000.
00:22.105: INFO:    No reboot logic message NrApiDecisionDialog(2), lParam=0x00000000 returned 0x00000000.
00:26.895: INFO:    No reboot logic message NrApiPreInstall(3), lParam=0x00000000 returned 0x00000000.
00:26.895: INFO:    No reboot logic message NrApiStartInstall(4), lParam=0x00000000 returned 0x00000014.
00:26.895: INFO:    Installing with the downloaded package. C:\Windows\TEMP\IE1A5E3.tmp\IE11-neutral.Downloaded.cab
00:26.895: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1A5E3.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
00:30.779: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1A5E3.tmp\IE11-neutral.Downloaded.cab /quiet /norestart' exited with exit code 0x800F081E (-2146498530)
00:30.779: ERROR:   Neutral package installation failed (exit code = 0x800f081e (2148468766)).

This tells me that the installer things that KB2834140 is a requirement, and the installer is downloading and trying to apply it - and failing.

If I try to download and install the update manually, I get the message

enter image description here

I've tried removing KB2834140 manually and rebooting ... but when I try again I get the same error.

Can anyone suggestion how to bypass the error, or at least get the installer to the point where it knows that KB2834140 is installed?

1

Managed to fix it: my VM was tied into the corporate WSUS server, which clearly is missing some vital updates. By bypassing WSUS and checking with WindowsUpdate directly, I was missing a ton of "Important" updates - after installing them, everything is now working and IE11 is running happily.

Now to figure out what's wrong with WSUS ...

1

For those that may stumble across this looking for an answer...

Make sure Platform Update for Windows 7 SP1 and Server 2008 R2 SP1 (2670838) is installed. I had the same problem trying to upgrade to any version higher than IE9 until I installed the update.

  • That kb is noted as a prerequisite for IE11 & solved the same error I had on my PC – gregg Apr 27 '18 at 19:55
  • This worked when tons else didnt. Note that c:\windows\IE11_main.log had this line which make it looks like it's installed: "00:09.095: INFO: Version Check for (KB2670838) of C:\Windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll: 6.2.9200.16492 >= 6.2.9200.16426 (True)". But installing it did not report it was installed already, and it made IE11 install work for me on 11/17/2018.I dl'd from here: support.microsoft.com/en-us/help/2670838/… – john v kumpf Nov 17 '18 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.