I have two windows machine on a home wired network, one running windows 7 (I will call it w7 from now on) and one running windows 8.1 (I will call it w8 from now on). Both machines could access each other's shared folders (shared using "advanced sharing", that is) until my internet service provider upgraded their modem over the week-end. Now w8 can access w7's shared folders, but w7 cannot access w8's shared folders. When typing the \w8 in windows explorer I get a message that says

Windows cannot access \\w8

and, in the details:

Error code: 0x80004005

Unspecified error

If I try the same thing in the start menu I get a different details section:

Error code: 0x800070035

The network path was not found.

If I enter \\[w8's ip address] either in windows explorer or in the start menu I get the same results as above.

I made sure that Client for Microsoft Networks was installed and checked on W7 and w8 for the Local Area Connection, as well as the connection to the Internet Service Provider.

There are no 3rd party firewalls on w7 & w8.

I made sure all these services were running on both w7 and w8

  • Computer Browser
  • DHCP Client
  • DNS Client
  • Function Discovery Resource Publication
  • Server
  • SSDP Discovery
  • TCP/IP Netbios helper
  • UPnP Device Host
  • Workstation

UPnP Device Host was not running on w7, but starting it made no difference.

Computer Browser & UPnP Device Host were not running on w8, but starting them made no difference.

I tried to map a network drive on w8 from w7 (using both ip address and name), choosing "connect using different credentials" as per a response on technet still yielded Error code: 0x800070035

I cannot ping w8 from w7 using either ip address or name, but w8 can ping w7.

There is also an xp machine on the same network. w7 & the xp machine can see each other. w8 can see the xp machine, but the xp machine cannot see w8.

It seems like this could be a Firewall configuration on w7. However, there are many, many inbound firewall rules, and I don't know which ones to check for.

  • What are the (local network) ip addresses of both computers and what is the subnet mask? Are they actually on the same network? Maybe W8 has switched to ipv6?
    – agtoever
    Aug 4, 2014 at 21:14
  • @agtoever the address of w8 is, subnet; the address of w7 is, same subnet. How do I know if w8 has switched to ipv6? Both computers list ipv4 & ipv6 addresses in ipconfig.
    – Jimmy
    Aug 4, 2014 at 22:41
  • You just gave us 2 IPv4 addresses. As long as both have an IPv4 address, they'll communicate over IPv4.
    – LPChip
    Aug 4, 2014 at 23:08
  • @LPChip and yet they don't! :(
    – Jimmy
    Aug 4, 2014 at 23:17
  • In case it helps someone else, I had the same symptoms but different cause; in the network connection properties "File and Printer Sharing for Microsoft Networks" was disabled.
    – stewbasic
    Apr 15, 2016 at 8:38

9 Answers 9


Beyond the other solutions solving generic / classic issues with this error code, another new issue can cause 0x80004005.

Since Windows 10 1709, the old SMB v1 protocol is not supported anymore by default, which is still used by several PCs or other network devices like routers providing a NAS. Note that SMB v1 might have been uninstalled on older Windows machines aswell. Follow these steps to re-enable it and access such devices again.

  • Press Win+R.

  • Type optionalfeatures and press Enter.

  • In the list appearing, make sure Support for SMB 1.0/CIFS File Sharing is checked.

    Depending on what you need you might only require the client or server component, and also install the automatic removal (which tries to protect you from SMB v1 security issues), but if you have no clue what I mean, just check the parent checkbox.

Restart your PC and try accessing the device again.

A typical device not supporting SMB 2 or newer are older FritzBox routers (popular in Germany), and if you try to access a USB hard disk attached to act as a NAS, you'll be unable to reach the router trying to connect to it.

  • 2
    My win10 default had the SMB1.0 SERVER enabled, but the CLIENT was disabled! Come one Microsoft... *facepalm*. This is an awfully unhelpful error message, I got to this solution from another site where someone suggested to try to map the shared folder as a network driver, using different credentials to ask for usr/pwd. Only then it gave me a meaningful error, saying "You can't connect to the file share because it's not secure. This share requires the obsolete SMB1 protocol". I wish google could give me this SE answer in the top results. ;(
    – msb
    Jul 30, 2018 at 19:29
  • 1
    Apparently at some point in 1809, they disabled it as well. I just had to re-enable it. quick way to get to the windows features window is WIN+R, "optionalfeatures". Enable the SMB 1.0 client.
    – Derek Wade
    Feb 6, 2019 at 21:25

Follow the instructions below. They might help. Or they might not

In the computer running Windows 8, press Win+R and in the Run command box, type:
control /name Microsoft.NetworkAndSharingCenter and press Enter.

Click on "Change advanced sharing settings" on the left pane and expand the "Private" sharing profile and make sure that Turn on network discovery and Turn on file and printer sharing are selected.

Expand the "Guest or Public" profile and make sure that Turn off network discovery and Turn off file and printer sharing are selected.

Expand the "All Networks" profile and scroll down to the bottom of the window and under "Password protected sharing", select Turn off password protected sharing.

Now, press Win+R and in the Run command box, type: \\Localhost. Verify that all your shared folders are present here.

Select a folder from the list and press Alt+Enter and in the Sharing tab, press the Share button and type in Everyone in the dropdown list and press Enter and set the "Permission level" to Read. Do this for every folder you want to share.

Finally, ensure that both computers (W7 and W8) have the same network mask.

Do this by pressing Win+R and in the Run command box, type: shell:ConnectionsFolder and select your network adapter for the wired Ethernet connection and press Alt+Enter. In the Properties window, scroll down to Internet Protocol Version 4 (TCP/IPv4) and double click it.

If the IP address and subnet mask have been entered manually, make sure the subnet mask matches that of the Windows 7 machine by following the same step on W7.

Now, find out the hostname of the W8 box by typing this into the Run command box:
cmd /c "hostname & pause".

Now switch to the W7 box and in the Run command box, type: \\HOSTNAME_OF_W8_BOX and see if you can access the files and folders on W8 now.

  • "Turn off password protected sharing" was off, but I tried turning it on as it seems to be what I need for "advanced sharing"? However turning it on did not make a difference. The shared folders are indeed present when viewing \\localhost on w8. I shared a folder as you suggested (that was previously off, as I was using 'advanced sharing'), but it didn't make a difference. The blocking issue appears that w7 (and other machines) just can't see (including ping) w8.
    – Jimmy
    Aug 4, 2014 at 23:05
  • Try turning password protected sharing off and sharing folders as I suggested. Also make sure network discovery is turned on.
    – Vinayak
    Aug 4, 2014 at 23:10
  • If that doesn't work, try creating a homegroup and make W7 participate in the homegroup and see if that helps.
    – Vinayak
    Aug 4, 2014 at 23:12
  • In my case when I open \\HOSTNAME between two win10 PCs I see list of all shared folders. The problem is that if I click any of the folders it starts "thinking" for a very long time before failing to open it
    – Pavel P
    Sep 16, 2016 at 17:52
  • @Pavel that could be a permissions problem. Check the Sharing tab in the Properties window of a folder you're sharing and click the Share button. Type in "Everyone" and click Add. If you're now able to access that folder from the other computer, you may need to change your sharing permissions.
    – Vinayak
    Sep 16, 2016 at 18:00

Here is a workaround.

Sometimes Network Discovery under windows simply won't work, but the network is present, just inaccessible.

Then, you should assign a static IP to the fileserver station.

Map the drive to the shared folder using the IP of the station instead of the computer name.



instead of the inaccesible


There are 2 active network connections on the windows 8 machines: Network 3, of type Ethernet, and Bell, a dsl connection requiring username & password. When I connect to the Bell connection then the machine gets assigned a public IP address. Anyway, the Bell connection was of type Private Network, and the Network 3 was of type Public Network -- exactly the opposite of what they should have been. After changing those settings, everything started working as expected.

It was trivial to change the Network 3 connection to be private (Windows + I, click on Internet access, then View Connection Settings at the top, where I could Select Network 3 and turn on "Find Devices and Content"). Making Bell public was a little more involved, as it does not show up under View Connection Settings. So I had to Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles, find the profile with Profile Name Bell, and change its category to 0 (i.e., leave it blank). See more detailed instructions & screenshots.


I fixed it with the following steps:

1- go start->control panel->device manager open it 2- in view menu tick "view hidden devices" 3- open network adapters branch. 4- you will see many adapters named Microsoft 6to4. (i had over 150 number of them). 5- delete all. 6- restart your pc.

However, while searching i found another useful resource which has several steps list other then the one above; so if you wish you may try this at http://appuals.com/best-fix-steps-fix-error-0x80004005/


Is your modem also the router that both pc's are connected to? If so, their update probably reset everything to defaults causing windows 7 to detect a new network. As a result, a popup is shown to ask what kind of network this is. If chosen for Public network, it will be very restricted. This is likely what happened.

Here's what you do on the windows 7 computer:

  1. Click on the network icon near the time on the bottom right.
  2. Click Open network and sharing center
  3. Below View your active networks on the left, click the blue text which is now probably saying Public network or possibly Home network.
  4. In the new dialog, select Work network.
  5. Click Close.

Things should now be working again.

If things are still not working, click the Change advanced sharing settings on the left and evaluate these settings. Do the same on the windows 8 machine. (The above 5 steps do not apply to windows 8. It will always be a Public network there, and windows 8 won't ask what network you have.)

  • w7 was on home network. Changing it to work network did not seem to make a difference. I also have an xp machine on the same network and it cannot see the w8 machine either. w8's advanced sharing all seem reasonable (turn on network discovery & file and printer sharing for private networks, off for public; all networks public folder sharing & password protected sharing are off. I tried turning on password protected sharing under all networks (as that is what I am trying to do, with advanced sharing?) but it did not make a difference.
    – Jimmy
    Aug 4, 2014 at 22:59
  • Actually, I see something suspicious on w8. Under "Network and Sharing Center", there are two active networks: "Bell" and "Network 3". Network 3 is of type Ethernet, and says "no internet access". Bell is of type "Bell", and has internet access. I 'dial' the Bell connection to have an external (public) IP. What is suspicious is that Bell is labelled "Private network", while "Network 3" is labelled "Public Network". It would seem to me that is should be the opposite? Can I force Windows 8 to make Bell a public network and Network 3 a private network?
    – Jimmy
    Aug 5, 2014 at 0:40
  • Do you make a VPN connection? If so, does everything work when you disconnect the VPN network? If so, edit your VPN connection, network tab, ipv4, uncheck use external gateway.
    – LPChip
    Aug 5, 2014 at 6:45

So recently I deployed Windows 10 to a few test machines in my office and had the issue of not being able to access the network share ie "\\USA\Shared" or "\\FRANCE\Shared" but "\\ENGLAND\Shared" worked fine as it was my local Share. This was only on my Dell Optiplex 990 which is using the Intel 82579LM Gigabit NIC. The laptops access the network shares fine. I looked at the reg HKLM\System\CurrentControlSet\ fix and also that the right network services were running.

Myself and my colleague in Shanghai thought it might be DNS issues but NSLookup was resolving perfectly. I went to: https://downloadcenter.intel.com/product/47549/Intel-82579-Gigabit-Ethernet-Controller where Intel have released new versions of the Network card within days of each other.

There was obviously some issues. After an update of the drivers and reboot my non local shares are working perfectly.


I had something similar, but I could connect to SOME shared folders, but not others on a single client PC. To make matters worse, I could connect to all of them from one login name on the client PC, but only some of them using another login name. And as far as I could see, both login names were set up on both PCs.

This article is what fixed it for me: http://www.howtogeek.com/howto/13197/map-a-network-drive-from-xp-to-windows-7/

I had what I THOUGHT was the same user name on the XP (host) machine, but couldn't connect to certain folders on it. It turns out that although the "Full name" was the same on both PC (in Admin, Local Users and Groups, Users), the "Name" was different. Once I added the same "Full name" to the host, everything worked as expected.

My guess is that the problem was caused because some folders had been created by one user on the host machine, and others (that I couldn't access) were created by the other.

By adding the user name for the client machine on the host machine, I got access to all the shared files.


I had a similar problem and ended up being that the user was accessing a network share with another user credential (mapped network drive) removing the user credential from the credential manager in control panel fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .