Update 2 : I have at long last found the source of the problem. This appears to be caused by my Logitech G35 headphones.


It's apparently a known problem, and has yet to be fixed.

Update: This same issue has appeared on another completely different system. It must be software related, something similar between the software on both machines must be causing the issue. The new machine is running Windows 8.1. A possibly related or unrelated issue that has popped up at the same time is that mmsys.cpl will not open (the audio device manager from control panel).

This also seems to affect Audio as well, something I had not noticed since I rarely listen to music. It may actually have something to do with audio rather than the video.

Whether I am watching a video on YouTube, watching a downloaded show in VLC, or streaming from Netflix, I have an intermittent problem where no videos will play past their first frame.

For any application that can play videos (Chrome, Firefox, VLC, WMP, Quicktime, etc) if I start a video it will show only the first frame and stop playing. Sometimes (but not always) I can seek through the video, and it will just be stuck at whatever point it was set too.

The problem pops up randomly and usually lasts for a few minutes. Rebooting will fix it, but it will come back later. If a video is playing there seems to be no problem, but once one ends if I try to play another it might not work.

Sometimes the page with a video will crash, or VLC might stop responding. But not always, in some cases everything seems to work perfectly except the video isn't playing.

The weirdest part is that while in most cases video is broken across the board, sometimes I can play some things in some applications.

  • In VLC I have only tried playing .mp4 files (I don't have anything else to play). VLC seems to always be effected when this happens.
  • Windows Media Player won't even show the first frame, it just seems to fail to load anything.
  • In Chrome there is some inconsistency, sometimes Flash works even if HTML videos will not.
  • In some cases only YouTube seems to have a problem. Sometimes nothing seems to play accept Hulu.
  • Netflix almost never works right.
  • Sometimes for HTML video instead of hanging on the first frame it seems to be unable to load the video at all.
  • The Netflix Windows 8 app sometimes just hangs at 97% loading.
  • Many times Firefox can still play video just fine even though Chrome can't.

I am totally perplexed by this, and its effect of all applications. I have done all the basic steps, rebooted, updated software, reinstalled software, checked for malware, installed all my windows updates. Everything I could think of. I search for info online, and wasn't able to find anything similar to this problem. I couple of threads about VLC freezing, but they didn't sound like this problem, nor did they have any solutions.

System specifications:

  • 2013 14" Razer Blade
  • Windows 8
  • CPU: Intel Core i7-4702HQ
  • GPU: Intel HD4600 / NVIDIA GeForce GTX 765M
  • Solid State Drive
  • 8GB RAM

And on:

  • Windows 8.1
  • CPU: Intel Core i7-2670QM
  • GPU: NVIDIA GeForce 540M
  • 8GB RAM

All graphics and system drivers have been updated via Razer Synapse as as per manufacturers instructions. On the other system drivers are all up to date.

Since this same problem is happening on two systems with different harware configurations I have to think it's a software issue. I followed the advice of one answer and contacted support, Razer RMA'ed the Blade, they reloaded Windows and I have yet to get it back so I don't have any way of compairing the software on the two computers

  • Sounds like a problem with your graphics to me. Did you changed any graphic settings prior to these problems? – Young Pizza Aug 7 '14 at 17:05
  • If this just happened recently, you could rollback to a previous system restore point. – harrymc Aug 7 '14 at 19:28
  • No recent changes to graphics settings. I did update the drivers after the issue appeared and it didn't effect it. As for a restore point, it's been a while since this popped up, so I would rather not do it. – zeel Aug 7 '14 at 20:28
  • You could roll back at least the video drivers. Better add your hardware specs to the post. – harrymc Aug 8 '14 at 6:17
  • have you checked your application logs? – Ben Plont Aug 13 '14 at 17:34

Okay, the best I can do here is to try and discount your codecs, if this doesn't work you're into the realms of video hardware, settings and drivers.

  • Get the latest version of VLC and install, (you may have already covered this)

  • Get the latest K-Lite codec pack from here and install both the codecs and Media Player Classic.

  • Get the latest Flash player update from the same link and install.

  • In Firefox -> Options -> Applications select the VLC or MPC plug-ins for playing video content in your browser.

At this point you should be able to play anything on or offline. Let us know how you get on, and good luck!

  • VLC has its own codecs for most video formats, so this answer doesn't address the problem. – harrymc Aug 8 '14 at 9:58
  • Indeed, but if VLC can't play it MPC can, normally, and vice versa. As I'd mentioned above, the idea of my post was to discount codec problems before moving on. Start with the easy stuff, eh? – doggyTourettes Aug 8 '14 at 10:33
  • VLC codecs are extremely reliable. Also it's highly unlikely for such a serious problem to exist in more than one codec. The problem must be in some software that is common to all codecs and players, meaning the video driver or even Windows. – harrymc Aug 8 '14 at 10:49
  • Tried installing codecs as recommended, no improvement. MPC stops responding when I try to open a video in it. VLC shows the first frame, as usual. – zeel Aug 8 '14 at 18:08
  • Have you tried disabling hardware acceleration in Firefox, and seeing if this helps the problem with online content? – doggyTourettes Aug 12 '14 at 16:29

I'm not sure if you're streaming or playing from HDD or both.

If you're streaming: - Try checking you're firewall configurations. - Try waiting, a little longer to clarify if it's a bandwidth/connection problem - With Netflix, sometimes browser configuration(ie, really secure settings) can interfere with the loading process. Plug-in configurations, such as NoScript for Firefox, can completely block connections. - Check your router configurations. ** Try resetting your internet options, connection interface setting, and your router&&gateway. If you're connection setting are too-strict this could be the culprit preventing you from streaming.

For MP4: - I can't really state anything more than has been said. ** However, if you are converting or have converted your files into MP4 formats that can sometimes cause problems depending on the converter you're using.

Let me know what you tried, what worked, and if you fixed the problem.

  • Already checked for firewall/bandwidth/plug-in/extension issues - no change. – zeel Aug 8 '14 at 18:11

When such a serious problem appears suddenly, the question that naturally arises is whether it is hardware or software.

For hardware, this would probably be a problem with the GPU. You could install and use some monitoring tools such as :

GPU-Z (the only one I have experience with)
NVIDIA System Monitor
GPU Shark
GPU Monitor

You could also try another GPU card in your computer, if you have one available and if that's at all possible with this laptop without breaking the warranty.

For software, the most you can do is rollback your system to a time from before this problem arrived, or at least do so for the video drivers.

If this doesn't help. the only advice I can give is to reinstall Windows and all applications from scratch. If the problem then returns, this is probably an indication of a real hardware problem.

If the computer is still under warranty, my advice would be to use it and let Razer technicians work on it, as they are better equipped.

In any case, you should, before anything else, get in touch with Razer Support, as they may have some useful advice or software for testing your computer. Do that even if the warranty has already elapsed.

  • I don't know how I would use those monitoring tools to identify a problem. – zeel Aug 9 '14 at 8:19
  • One basically studies the sensor data, mostly these dealing with temperature, to see if one is much higher compared to the readings you get when everything works fine. If temperature is the cause, you will need to take steps to better cool your laptop when watching video. – harrymc Aug 9 '14 at 9:19
  • I have sent it in for warranty repair. No idea yet what the problem is, but I'm sure they will either find it or replace it. – zeel Aug 14 '14 at 20:05

Your buffers may not work properly. There are many articles related to the Youtube Buffers it uses to download videos. Waiting for an application to initialize helps.

  • That wouldn't apply to VLC or WMP playing offline content. – zeel Aug 8 '14 at 2:37

If all media players and HTML5 video don't work, but Flash does, it leads me to believe it may be a problem with the DirectShow/WindowsMediaFoundation stack. Most likely in the output renderer. Check your system event log to see if there might be any other errors that would point to incorrect permissions, and use sfc to see if there are some bad system files. You may also want to try updating DirectX, which will include some DirectShow/WMF components, although if you're in Win8, they should be fairly recent and it might not do anything.

You can also try using GraphStudio or something and building out a filter graph to see exactly which renderer is being used.


This issue is caused by some bug in the software or drivers for Logitech G35 headsets. There are multiple threads on the Logitech forum, most notably this one, no fix is available at this time (and considering how long this has been a known issue, it may never be resolved).

In some cases unplugging the headset, restarting the Logitech software, and restarting the affected applications can temporarily "fix" the problem without resorting to a full reboot of the system.

The forum thread suggests reinstalling the Logitech software and drivers, and using a different USB port. Mileage seems to vary on whether any of those options will help (sometimes they will at least seem to help for a while).

For more on solving this see: Logitech G35 headset intermittently causes all media to freeze or crash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.