Animation of swiping the lock screen away

I'm currently running centos 7 (the server with gui config) on a VM. I'd like to keep the log in screen, but the 'phone' style pre-login lock screen that requires a swipe to access the main login screen is annoying. Is there any simple way to disable it and go directly to the log in screen?

  • 34
    The enter key also works ;) But granted, it is incredibly stupid.
    – bjanssen
    Aug 6, 2014 at 5:44
  • 56
    I suppose a phone is better then a toaster.
    – n00b
    Aug 6, 2014 at 13:29
  • 22
    +1 I can sympathise with this. Windows 8 also has this. I wish OS-makers would learn to keep their Phone OSs and PC OSs separate.
    – Pharap
    Aug 6, 2014 at 17:53
  • 12
    GNOME 3 is still an abomination. Switch to KDE ... or anything else! Aug 6, 2014 at 21:09
  • 73
    OH GOD IT'S INFECTING LINUX NOW? Aug 7, 2014 at 3:13

5 Answers 5

  • You will need to install the gnome-shell-browser-plugin package from yum for the extensions to work. I'd also add curtains up worked closer to what made sense for me (pressing any key got rid of the 'curtain') and disable-screen-shield didn't seem to work.
    – Journeyman Geek
    Aug 6, 2014 at 5:45
  • 17
    Do you really need the extension? I'm running Gnome Shell 3.10 (I think), I don't remember installing any extension, and the pre-login screen disappears immediately when I start typing. In fact, it's one of the best things about Gnome shell -- you don't need to hit a key to "wake up" the screen first, just start typing your password (even on a black screen) and every character will be entered into your password.
    – nemec
    Aug 6, 2014 at 16:20
  • 1
    @nemec exactly what I said in my answer.
    – Braiam
    Aug 6, 2014 at 20:28
  • 2
    For some reason it didn't do that for me when i tried it. And it was annoying the heck out of me. I'll probably roll back to an earlier snapshot to double check. Still the 'shade'/Curtain style thing is entirely redundant in a non touchscreen device.
    – Journeyman Geek
    Aug 7, 2014 at 14:51

Just start typing your password and the screen will just go away. No need to press/swipe/whatever anything at all.

  • 60
    Terrible discoverability, acceptable usability. A good example of the difference between the two!
    – RomanSt
    Aug 7, 2014 at 15:43

I found this in an Arch Linux forum and it appears to work to remove the swipe screen (screen shield)

gsettings set org.gnome.desktop.session idle-delay 0

Found here: https://bbs.archlinux.org/viewtopic.php?pid=1351594#p1351594

  • 4
    This appears to disable the screen lock itself, not the screen shield part of the screen lock. In other words, your screen will now never lock at all.
    – Haydentech
    Feb 28, 2018 at 20:21
  • @Haydentech in Centos 8 with XFCE, this gsettings one-liner works just fine. I still do get a "session locked" password dialogue after some timeout, but it's some standard windowed thing. The ugly swipey curtain is gone for good.
    – frr
    Jun 15, 2021 at 11:26

My issue is that moving the mouse alone is not enough to close the shield. On a media centre machine the last thing you want is having to reach for the keyboard or try and drag upwards. The extensions don't seem to be kept updated with the latest versions of Gnome and the workarounds to do that are scary.

My approach was to disable blanking in Gnome and then fall back to using X11 DPMS to switch off the monitor.

  1. Disable gnome screen blanking. This stops the shield but means the monitor remains permanently on (fixed by DPMS below):
gsettings set org.gnome.desktop.session idle-delay 0
  1. Disable gnome power plugin (this plugin will always disable the DPMS timeouts you set below)
gsettings set org.gnome.settings-daemon.plugins.power active false
  1. Activate DPMS by adding these lines to /etc/X11/xorg.conf (create if it doesn't already exist). The different power saving modes no longer apply to LCD screens. Time is in minutes.
Section "ServerLayout"
     Identifier "Default Layout"
     Option "BlankTime" "0"
     Option "StandbyTime" "0"
     Option "SuspendTime" "0"
     Option "OffTime" "10"

Or just install the good all xscreensaver. How-to.

Then set the shortcut on the command xscreensaver-command -lock, reboot, done.

  • Can't blame Ubuntu for this. They we're using unity back then
    – Journeyman Geek
    May 9, 2019 at 11:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .