0

First I am able to use simple port forwarding on my router to access each IP cam individually. This is an unsecure method and is exactly the solution I a trying to get away from.

I am a Linux professional. I can handle my own on the Ubuntu side. I am not so much technically savvy on the Android side. I've spent a good amount of time trying various methods mentioned below. The primary problem is that I just don't have beaucoup amount of time debugging to get this to work. Hence my post.

I am looking for the simplest solution to achieve my requirement. I want to securely access multiple services from my Android phone over 4G/3G on my natted home network using my Ubuntu server as the gateway. When i I say securely I mean, using an encrypted protocol to connect to my Ubuntu server, using multiple levels of authentication reaching my final end point application such as my IP webcam.

My phone is a HTC One M8 running Android 4.4.2 rooted using Weaksauce. The server on my internal network is Ubuntu 14.04.

I've unsuccessfully tried using Openvpn v2.3.2 on ubuntu and OpenVPN on my Android. This method and the other listed below I've spent hours trying get it to work. Way too many permutations of configuration and application choices to even attempt to list hear.

I've tried PPTP v1.3.4 on Ubuntu with the Android VPN client unsuccessfully

Again I am looking for the quickest way for my requirements to be met. I am open to the above methods but thinking below is the way to go.

The solution I am leaning towards is using ProxyDroid and SSH Autotunnel on my Android to port forward port 3128 to reach squid v3.3.8 on my Ubuntu.

The current problem I am running into is that SSH Autotunnel complains that it cannot create the port forward because port 3128 is already opened by squid. I've used this solution years ago using Putty on Windows and squid on my Linux system. Technically I am doing the same thing with SSH Autotunnel so I do not understand why I am getting this error this time.

I really appreciate anybody who has a few minutes to help me get up and running.

--Thanks, Chris

  • Have you looked at chrome remote desktop? It's not super geeky but it sounds like exactly what you are looking for. It is kinda geeky to get it configured in Linux though, so it shouldn't be too big of a let down. – user1998698 Aug 6 '14 at 6:06
  • Very cool! It actually lets me do what I need. The interface is just to difficult to work to be my permanent solution. It's a nice tool/app to have in time of need.. Thanks !, Chris – Chris Boyd Aug 7 '14 at 14:43
0

I've successfully set up a L2TP/IPSec PSK VPN between Ubuntu 14.04 and Android 4.1.2 (running on a Samsung Galaxy S3).

On the Android side, I've used the system VPN configuration tools which are available on the stock software.

[screenshot](http://f.cl.ly/items/1y180o1j2i0a1w1D2u3k/Screenshot_2014-08-06-09-48-59.png)

On the Ubuntu Side, I've pretty much followed this tutorial and changed the config according to my specific situation.

  • Thank you for your answer. I am having such bad luck getting a solution to work. I put in a good amount of time configuring and debugging to run into a problem I can't solve. That is what has happened here. I am hoping you can help me through this problem. ipsec verify conplains "Two or more interfaces found, checking IP forwarding [FAILED]". ifconifg show this added wlan0 interface that I cannot figure out how to delete. ubuntu auth.log report these errors when I try to connect (70.192 is my android) " – Chris Boyd Aug 7 '14 at 14:35
  • ubuntu pluto[7684]: packet from 70.192.203.214:3782: received Vendor ID payload [RFC 3947] method set to=115 ubuntu pluto[7684]: packet received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-02] meth=107, but already using method 115 ubuntu pluto[7684]: packet from 70.192.203.214:3782: ignoring Vendor ID payload [FRAGMENTATION 80000000] ubuntu pluto[7684]: packet from 70.192.203.214:3782: received Vendor ID payload [Dead Peer Detection] ubuntu pluto[7684]: packet from initial Main Mode message received on 192.168.10.104:500 but no connection has been authorized with policy=PSK – Chris Boyd Aug 7 '14 at 14:45
  • I don't think the "two or more interfaces" notice is the root of the problem. Please check this thread: lists.openswan.org/pipermail/users/2013-July/022520.html – Luc van Donkersgoed Aug 7 '14 at 19:19
  • Thanks again. I'm going to close this post and open a new regarding where I am stuck at now LOL!. – Chris Boyd Aug 7 '14 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.