-2

My user works on a piece of software that requires me to edit the Config.nt file in the windows directory to work.

Now I navigated to the file location and tried to edit the file by opening with Notepad (as you would any .bat file). I edited it all well and good albeit with a little concern as to how empty the config .sys file was. (it consisted of only one small line which happened to be the one I needed to edit) when I went to save it I got Access Denied. at this point I was logged in as local administrator of the computer. I then tried logging in as the network admin, my own network admin account, and even tried to create a new administrator to see if I could start the permissions from scratch.

I then tried to right click on the windows file and opened properties to change the security. It allowed me to click Edit but did not allow me to add or delete a user and all the tick boxes are greyed out... is there any way I can gain full control of the windows file/ directory in Windows 8? it seems pretty much impossible.

[Update]

I have tried the Command lines suggested in the linked question and none of these work I still get permission denied or that the changes couldn't be made even with elevated cmd. will deactivating UAC make any difference?

  • And what changes would be required? This file is no longer used and only remains for (whatever) compatibility reasons. – Daniel B Aug 6 '14 at 9:01
  • the line is "Pages=40" I need to change it to "pages=50" its such a simple change that's the annoying thing! – ThunderToes Aug 6 '14 at 9:03
  • 1
    There’s no such thing as a Pages directive...? Anyway: If the program has DOS requirements, you should use a DOS emulator. Because Windows NT does not have DOS, at all. – Daniel B Aug 6 '14 at 9:20
  • possible duplicate of How do I get permissions to delete files on Windows 7? – and31415 Aug 6 '14 at 9:44
  • I know you're not deleting files, it's the answer that count as a duplicate (i.e. taking ownership/changing permissions). Did you try to use said commands from the recovery environment? – and31415 Aug 6 '14 at 9:55
2

UAC prevents users with administrator privileges to change system files when you open them through Explorer. I am not sure about Windows 8, but in Windows 7 you could start Notepad with the 'Run as administrator' option, open the file from notepad, edit and save it.

  • It doesn't even allow me to save in the directory when I navigate there in the save box in Notepad there aren't any files visible and it says I don't have the permission to save in the location – ThunderToes Aug 6 '14 at 9:05
  • And you did make sure to use the 'run as administrator' option when starting Notepad? – mtak Aug 6 '14 at 10:10
  • yes I tried and the same message appeared – ThunderToes Aug 6 '14 at 10:25
0

I managed to get the icacls and Takeown to work in elevated command prompt and this helped me to take ownership and gain full control rights to the File. what I wasn't aware of was that there were two different Config.nt files one in the root of System32 and another in one of the folders in WinSxS. I happened to give myself control to the wrong config file. I corrected this, changed the Files=40 to Files=50 and it worked fine. StockPro is now fully operational.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.