0

I backed-up important files from my old PC onto an external hard drive and whenever I try to delete, move, or open one of these files or folders, it tells me I do not have permission (access denied) to do that.

So I took ownership of those files, with elevated CMD, using:

takeown /f filename

The result was "SUCCESSFUL", however, this has not solved the problem. So I right-clicked a file > Properties > Security > Edit > Add > Typed in my current Name > OK > Apply - then tried to access the file again without success.

So I then tried > Properties > Security > Advanced > Owner: Change > Enter my name > Apply - then tried accessing the file again - no luck.

How can I regain full control of these files?


Update:

19:50PM AEST - 6/8/14:

The result of icacls bounce.wav was:

E:\Audio>takeown /f "bounce.wav" /a & icacls "bounce.wav" /grant:r *S-1-5-32-544
:F /q

SUCCESS: The file (or folder): "E:\Audio\bounce.wav" now owned by the administra
tors group.
Successfully processed 1 files; Failed processing 0 files

E:\Audio>icacls "bounce.wav"
bounce.wav BUILTIN\Administrators:(F)
           Home-PC\Jason:(I)(F)
           Everyone:(I)(F)
           BUILTIN\Administrators:(I)(F)
           NT AUTHORITY\SYSTEM:(I)(F)

Successfully processed 1 files; Failed processing 0 files

Though, I am still unable to copy/move/open this file. The error given is:

You require permission from Administrators to perform this action.

But I am an administrator.

8
  • Try running the following command: takeown /f "file" /a & icacls "file" /grant:r *S-1-5-32-544:F /q
    – and31415
    Commented Aug 6, 2014 at 9:38
  • @and31415 thanks, I just ran that cmd and it said "SUCCESSFUL, file now owned by admin group" but I'm still unable to open/copy/move the file.
    – jay_t55
    Commented Aug 6, 2014 at 9:44
  • @and31415 I have updated my question to include the results from your last comment.
    – jay_t55
    Commented Aug 6, 2014 at 9:53
  • Anybody have any ideas?
    – jay_t55
    Commented Aug 6, 2014 at 10:28
  • @and31415 I figured out what the problem was; the problem was that these files (many and important ones) - I (at some point) decided to check the "Encrypt contents to secure data" option in Properties > Advanced - and that was done on the old computer (which I no longer have) and so on this new computer - they're still encrypted, but nothing is working cause they're encrypted. I even tried using RichCopy to decrypt them as suggested on TechNet site but it fails for most of the files saying "file not found" but it's clearly there.
    – jay_t55
    Commented Aug 6, 2014 at 15:42

1 Answer 1

0

This is my "chown.bat" (unix folks will laugh at me using that name):

    for /r %fn in (*.*)  SetACL -on "%fn" -ot file -actn clear -clr dacl,sacl
    takeown /F * /R /D  Y
    icacls   *.* /T /C /grant %_winuser%:(D,WDAC)
    icacls    .  /T /C /grant administrators:F System:F everyone:F

SetACL is a 3rd party utility that needs to be in your path.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .