As the title says whenever I drag a file over a disconnected mapped network drive Windows Explorer freezes.

After a minute it unfreezes again. Is there any way to fix this behaviour?

It looks like this when it freezes enter image description here

  • Does it always happen, or only if you havn't touched the network drive for a while? Note the red "x", this means it's currently disconnected, perhaps due to being idle. When you roll over it, you're waiting for the connection to be re-established. If we can establish if it's due to idle, that idle time can be adjusted. – Ƭᴇcʜιᴇ007 Aug 6 '14 at 13:22
  • As it turns out I can't actually connect to this drive right now. It looks like when I drag files past it tries to connect to it and then freezes. I get the feeling that this is a bug in how windows handles network drives. – VBwhatnow Aug 6 '14 at 13:34
  • 1
    This is a sucky problem with Windows that has existed since windows XP! I really wish someone had a real solution to this! – Atomiklan Jun 28 '18 at 2:23
  • Is there any way to remove mapped network drives from navigation pane? – m4heshd Aug 23 '19 at 17:42

To minimize traffic, Windows doesn't re-establish an idle/disconnected mapped drive connection until you go to use it.

Dragging a file over it in Explorer is enough for the OS to consider that you're trying to use it.

Similarly (haven't actually tested just now, but based on memory), if you have a hard drive that's sitting idle and had been spun down, and you dragged a file over it's letter in Explorer, it'd spin up, and Explorer would freeze for a bit until it heard back from the drive (or gave up waiting for it).

| improve this answer | |
  • 2
    It's totally a bug :( Thanks anyway. Marking as Accepted – VBwhatnow Aug 11 '14 at 7:48
  • It's not a bug, it's the way Windows behaves by default... there is a sane reason why it's defaulted to operate in this manner, however I can't recall the exact wording & do not wish to paraphrase inaccurately. This is a feature that can be disabled, but do not recall how; there is a network setting somewhere that will disable Windows attempting to check if a mapped drive has a live connection or when a file drags over it, however I can't recall what it was I had to set to prevent it from doing so. While this doesn't provide much help, I at least wanted to share that it is possible to disable. – JW0914 Sep 8 '17 at 0:02
  • 1
    The bug's still there even on W10 and it's so annoying – m4heshd Apr 24 '19 at 14:28
  • @JW0914 It absolutely is a bug. Windows Explorer could do whatever it's doing in a background thread and not lock up the UI. – Tibi Feb 3 at 8:46
  • @Tibi A bug would signify something is wrong in the code and it's not... this is the expected behavior of Windows Explorer. I can't provide a technical explanation but did provide a general one in my prior comment. If you wish to understand the technical reasons why this occurs, researching how and why Windows Explorer handles network shares would be a good place to start. – JW0914 Feb 3 at 12:17


  1. Vote on this bug: https://aka.ms/AA2pzti

  2. This MS support conversation suggests checking your hover response time (mine is the default and I still have the problem): https://answers.microsoft.com/en-us/windows/forum/windows_7-files/windows-explorer-freezes-for-a-few-seconds/612d7e98-ee13-440d-969e-d6a72c67ead8

Quote from LuckySoul777:

I know this is an old thread, but I stumbled over it when I was looking for a solution. Since I have found one now, here it is.

Basically the "MouseHoverTime" value under HKEY_CURRENT_USER/Control Panel/Mouse in the registry has been reduced to a ridiculously low value. Who did it? I don't know. In my case, it was 8 (ms)! By changing it back to the default value of 400, my problem is solved. Hope this is useful for everyone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.