I have a flash drive that has some old install software on it that I want to format and use for personal use as a storage device instead. However, when I formatted it, it simply formatted a flash drive partition (3.6g available) and also kept the install software active in a different drive letter (4.0 gb used). Essentially, my flash drive is acting like a USB device as well as a virtual disk. I cannot format the virtual disk portion (the option is greyed out when I right click on the drive), and right clicking on my PC and clicking manage only shows that the flash drive and the virtual disk are, according to my windows 8 PC, completely separate and unrelated. going to command prompt as an admin and typing format e: /fs:NTFS /p:2 (the disk drive) yields no results. typing format h: /fs:NTFS /p:2 (the USB) doesn't do anything either.

I found this topic from a person who had the same issue that I did. I received my flash drive in 2011, however, and the flash drive itself I believe is only 8 gigs (4 allocated to each drive?) Do I have a similar issue? Is there a way to merge the drives? if not, can I at least somehow wipe the virtual disk portion?

EDIT: The disk portion is CDFS partition and there seems to be a lot on the internet about how to remove it, but a lot of websites just tell you to "select format" (which doesn't work in my case).

I have attached a picture below for some clarity:

my windows explorer with the un-formattable extra drive


Try this options:

Option 1: Using command prompt:

cmd->attrib H: -s -r /s /d

This removes any locked system files that maybe disabling format options in the flash drive.

Then proceed with reformatting of the flash.

Option 2: Download the application associated with the model of the flash and use this to format or reset the flash to factory defaults.

  • when I type in the command you gave me, it returns the error File not found - H:. I have no idea what the model is (it's probably a proprietary thing from the company that gave it to me, so it probably doesnt have an uninstall application either) Aug 9 '14 at 5:43

If your USB Drive is acting as a Disk Drive here is what you have to do:

1) Insert your USB Drive into your computer;

2) In the search bar type: "Computer Management"; enter image description here

3) A window will appear. On the left side select: "Disk management" under "Storage"; enter image description here

4) On the bottom, you'll see all disks available (like (C:) and (D:) drive) as well as your USB Drive. (It should say how many GB it has and it should also say "removable" meaning it's a USB Drive. See Picture above)

Important note: your (C:) and (D:) drive should appear with a blue bar on top and your USB Drive with a black bar on top. The black bar means the device is not working properly. (In the Picture my USB Drive appears with a blue bar on top because I have already solved the problem and it's now working properly)

5) Select your USB Drive and click on "More actions" under "Disk Management" on the "Actions" column on the right side. enter image description here

6) Browse between the options and you should see something like "Add new volume", "Format" or "Change letter and path of unit".

7) A new window should pop up when you click one of the options above. Click "Ok" and you should be able to create a new volume or change the current one.

This should fix the problem. In one of the options above, it will ask you to choose a letter you want to set to your USB Drive. The letter you choose is up to you and it will have 0% affect on the way the USB device Works. You can change it later. (Usually when you connect a USB into a computer it shows up as (F:). This means if you want, you can choose any letter so it would show up as (G:) or (N:) for exemple.)

I apologize if the instructions are unclear or if the name of the options is different. After fixing the problem on my own USB Drive the options changed a bit and it was difficult to remember every step. Also, my system is not in english so if the name of the options is not 100% correct, I apologize once again.

If you have any doubt or problem make sure to let me know, I'll do my best to help you out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.